HomeDashboardFAQSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksMemberlistLog in
Share | 
 

 96 erratic idle

View previous topic View next topic Go down 
AuthorMessage
jbeganny
Member


Name : John Beganny
Location : Litchfield, Maine
Joined : 2011-09-05
Post Count : 120
Merit : 2

PostSubject: 96 erratic idle   Sat Jan 24, 2015 11:46 pm

This pertains to a 96 Riv without the SC. This may have started when got water in the gas tank. I replaced the fuel pump, changed the fuel filter, and drained the tank. After that it still would not start until I added three cans of dry gas. I assume I must not have removed all the water from the tank. Now it starts right up but immediately idles at about 3500 rpm's for a few seconds and then dies unless I hit the accelerator again and then it idles at 3500 again for a few seconds. It will keep running if I keep hitting the gas before it dies . It is very cold here this time of year so it takes a few minutes to get it up to temperature but after it warms up it will idle on it's own. After this it runs OK as long as it is under acceleration but when it comes to a stop it idles rough. Previously this car ran great all the time. Never a problem. Any suggestions?
Back to top Go down
robotennis61
Expert
avatar

Name : robotennis
Age : 55
Location : las vegas
Joined : 2007-12-17
Post Count : 5558
Merit : 142

PostSubject: Re: 96 erratic idle   Sun Jan 25, 2015 2:50 pm

Just a suggestion,remove your Throttle position sensor and spray with Electra-Clean,and dab on a little Dielectric grease,and replace. Do the same for all the sensors in the engine bay including the coil
packs and plate


Last edited by robotennis61 on Thu Jan 29, 2015 7:47 pm; edited 1 time in total
Back to top Go down
AA
Administrator
avatar

Name : Aaron
Age : 39
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18266
Merit : 237

PostSubject: Re: 96 erratic idle   Sun Jan 25, 2015 3:18 pm

Heya, robo. Hope you had a nice holiday. Welcome back.

_________________
'98 SC Riviera 268k miles 298 HP/370 TQ 0-60: 5.79s ET: 13.97 @ 99.28 4087 lb 20.1 avg MPG Nelson Ledges Lap: 1:30
3.4" pulley AL104 plugs 180 t-stat FWI w/K&N 1.9:1 rockers OR pushrods LS6 valve springs SLP headers ZZP fuel rails
KYB GR2 struts MaxAir shocks Addco sway bars UMI bushings GM STB Enkei 18" EV5s w/ Dunlop DZ101s F-body calipers
EBC bluestuff/Hawk HP plus SS lines Brembo slotted discs DHP tuned Aeroforce Hidden Hitch


'05 GTO 49k miles 0-60: 4.8s 16.9 avg MPG Nelson Ledges Lap: 1:26
Because fun
Back to top Go down
http://www.cardomain.com/ride/657082/4
robotennis61
Expert
avatar

Name : robotennis
Age : 55
Location : las vegas
Joined : 2007-12-17
Post Count : 5558
Merit : 142

PostSubject: Re: 96 erratic idle   Sun Jan 25, 2015 4:09 pm

Thanks buddy! Still a fan of the site.Just been busy with the Riv and accompanying running issues
Runs like a champ now! banana 3gears
Back to top Go down
matt270avian
Addict
avatar

Name : Matt
Age : 21
Location : Frederick, MD
Joined : 2012-01-15
Post Count : 2671
Merit : 49

PostSubject: Re: 96 erratic idle   Sun Jan 25, 2015 4:21 pm

Check/change your plugs and oil. Mine ran like that when the gasket from where the TB meets the SC didn't seal and coolant got into the engine.
Back to top Go down
 
96 erratic idle
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Difficult Starting/ erratic low speed running
» erratic shifting with th350
» speedo not working
» Odd Neutral Warning light behaviour
» First time use with GPX 5000 question

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   Supercharged 3800 Tech :: Series II Engine & Transmission-
Jump to: