HomeDashboardFAQSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksMemberlistLog in
Share | 
 

 Rough idle after hot restart

View previous topic View next topic Go down 
AuthorMessage
SpiralArchitect
Rookie


Name : Jesse
Joined : 2016-04-01
Post Count : 12
Merit : 0

PostSubject: Rough idle after hot restart   Tue May 17, 2016 3:00 pm

Hi gang,

I have a 95' Riv that typically runs great, but recently when I start the engine when hot (like after stopping to fuel up), the engine idles very rough, best way to describe it is "chugging", after a few seconds it will smooth out to a high idle then settle into a normal idle, when this happens the check engine light comes on and stays on till next restart, engine starts and idles fine every time when cold.
I have a very nice Bosch code reader, but as most of you know, the 95' is a crossover year (OBD-l computer with an OBD-ll interface) so I can't download the codes, and the only place locally that can read the codes charges $89.00 to do it, so I'm hoping someone here has some ideas.
I have recently replaced the TPS, fuel filter, and plugs & wires, any thoughts would be appreciated....thanks!
Back to top Go down
albertj
Guru
avatar

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 6741
Merit : 123

PostSubject: Re: Rough idle after hot restart   Tue May 17, 2016 6:58 pm

you need a scanner not a code reader.

My guess is the MAP died of old age.

Albertj
Back to top Go down
SpiralArchitect
Rookie


Name : Jesse
Joined : 2016-04-01
Post Count : 12
Merit : 0

PostSubject: Re: Rough idle after hot restart   Wed May 18, 2016 8:14 am

My mistake, I do have a scanner, but it's not compatible with the 95', the 95' has an OBD-l compliant computer but an OBD-ll plug under the dash, it simply will not communicate with the computer.
I've read there are some semi-affordable scan tools that will overcome this problem, but I just dropped $300 on the Bosch unit I have (that says it's compatible with my Riviera on the packaging), unfortunately it is not, I even called Bosch customer service where I was informed the scanner was NOT compatible with the 95" Riviera but was told I could not return it, same story from the auto parts store I bought it at, so I just can't afford to buy another scan tool at this time.
Is there a way to test the MAP sensor "hillbilly style" or do I need a compatible scanner?
If not, I guess I'll just have to take it to the shop and see what they say, I love this "era" of Rivieras but I sure am getting tired of pouring buckets of money into it just to keep it running decent, wish I could afford to replace it.....lol.

Thanks again for your response and suggestion, I appreciate it !
Back to top Go down
SpiralArchitect
Rookie


Name : Jesse
Joined : 2016-04-01
Post Count : 12
Merit : 0

PostSubject: Re: Rough idle after hot restart   Fri May 20, 2016 3:00 pm

Boy did I luck out !!!......My whole "hot start" problem was simply the fact that after the mechanic changed my TPS he did not get the plug in all the way, I pushed it in till it "clicked" and the car is fine now.....who'd of thunk it, eh?....lol.
Just wanted to post it so anyone else experiencing this problem can be sure to check the TPS and it's plug.

Thanks again albertj for your suggestions, they were very informative, but I'm happy it turned out to be so simple.

As long as I'm here, can anyone suggest an affordable scan tool that overcomes the whole 1995 OBD-l computer/OBD-ll interface issue?
Back to top Go down
 
Rough idle after hot restart
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Leaky Intakes - rough running
» Same story...over fueling rough running
» Stalling/running rough
» Rough running, advice please
» Rough noise

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   Supercharged 3800 Tech :: Series II Scans, Tuning, PCM-
Jump to: