The 8th Gen Riviera Resource
 
HomeDashboardSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

Share
 

 High idle, no check engine light

Go down 
AuthorMessage
SpiralArchitect
Rookie


Name : Jesse
Joined : 2016-04-01
Post Count : 12
Merit : 0

High idle, no check engine light Empty
PostSubject: High idle, no check engine light   High idle, no check engine light EmptyWed Jun 15, 2016 6:49 pm

Hey gang,

My 95' series l s/c Riviera idles high (approx. 1200 rpm) most of the time, once in awhile if the engine is hot and the ambient temperature is above 75 it will idle down to about 800 rpm.
I have recently replaced the TPS, plugs & wires, and replaced the 195 thermostat with a 180.
The curious thing is that I get no check engine light, so no codes ???

Any thoughts or suggestions would be appreciated...............thanks!!!
Back to top Go down
Abaddon
Expert
Abaddon

Name : Scott
Location : Macomb, Michigan
Joined : 2010-02-24
Post Count : 4309
Merit : 185

High idle, no check engine light Empty
PostSubject: Re: High idle, no check engine light   High idle, no check engine light EmptyThu Jun 16, 2016 9:03 am

You've either got a vacuum leak, or a possible bad IAC motor.
Back to top Go down
SpiralArchitect
Rookie


Name : Jesse
Joined : 2016-04-01
Post Count : 12
Merit : 0

High idle, no check engine light Empty
PostSubject: Re: High idle, no check engine light   High idle, no check engine light EmptyThu Jun 16, 2016 9:31 am

Thanks for the ideas, I'll check them out and post my findings.
Back to top Go down
SpiralArchitect
Rookie


Name : Jesse
Joined : 2016-04-01
Post Count : 12
Merit : 0

High idle, no check engine light Empty
PostSubject: Re: High idle, no check engine light   High idle, no check engine light EmptyThu Jun 23, 2016 11:15 am

Okay, I changed the IAC and found no vacuum leak, no change, the car is still idling at 1200 rpm.

Here is a little more information though, the high idle condition started the same time I switched out the 195 thermostat to a 180, is it possible that is causing the computer to put the engine into a high idle till it see's 195 temp?
I've read in many posts that the car will perform better with the 180 stat, and I have to agree the car seems to run better from a performance perspective, but I've never seen where anyone has had it cause a high idle condition.
Back to top Go down
Abaddon
Expert
Abaddon

Name : Scott
Location : Macomb, Michigan
Joined : 2010-02-24
Post Count : 4309
Merit : 185

High idle, no check engine light Empty
PostSubject: Re: High idle, no check engine light   High idle, no check engine light EmptyThu Jun 23, 2016 5:46 pm

SpiralArchitect wrote:
Okay, I changed the IAC and found no vacuum leak, no change, the car is still idling at 1200 rpm.

Here is a little more information though, the high idle condition started the same time I switched out the 195 thermostat to a 180, is it possible that is causing the computer to put the engine into a high idle till it see's 195 temp?
I've read in many posts that the car will perform better with the 180 stat, and I have to agree the car seems to run better from a performance perspective, but I've never seen where anyone has had it cause a high idle condition.

No. A T-stat change will not cause a high idle.

How did you check for a vacuum leak? There are many ways to skin a cat, but some ways are more efficient....

Does the idle vary at all, or is it a constant 1200rpms?
Back to top Go down
SpiralArchitect
Rookie


Name : Jesse
Joined : 2016-04-01
Post Count : 12
Merit : 0

High idle, no check engine light Empty
PostSubject: Re: High idle, no check engine light   High idle, no check engine light EmptyFri Jun 24, 2016 8:18 am

I visually inspected the vacuum lines for cracks, made sure there were no lines disconnected, then sprayed carb cleaner around all vacuum connections and intake manifold.....no effect.
Next I changed the IAC solenoid, again....no effect.
If I "goose" the accelerator the idle will drop to normal but then immediately go back to 1200 rpm.
I have a new vacuum gauge that was purchased for another vehicle but never used, should I install it in the Riviera, and if so where is the best place on the 3800 to make the connection, also what sort of reading should I get at idle?

Thanks for all the help!
Back to top Go down
sloshua
Member
sloshua

Name : sloshua
Age : 42
Location : Lebanon,MO
Joined : 2014-06-08
Post Count : 80
Merit : 1

High idle, no check engine light Empty
PostSubject: Re: High idle, no check engine light   High idle, no check engine light EmptyFri Jun 24, 2016 8:34 am

i have a 95 and have rebuilt the topend it pulls about 18 inches of vacuum. Mine also idles at 1200 rpm in park some times. If I turn of car off and turn the key back it resets the iac and then idles lower at about 800 rpm. Im still chasing this problem as well could be weak alternator could be funky temp sensor no cel light on my car as well when it does this. It runs great but the damn thing just has some quirks to it some times....
Back to top Go down
LARRY70GS
Aficionado
LARRY70GS

Name : Larry
Age : 63
Location : Oakland Gardens, NY
Joined : 2007-01-23
Post Count : 1687
Merit : 111

High idle, no check engine light Empty
PostSubject: Re: High idle, no check engine light   High idle, no check engine light EmptyFri Jun 24, 2016 1:21 pm

There should be a nipple on top of the engine where the power brake booster line goes.  That will read manifold vacuum.  There is also a hard plastic line the runs from the supercharger snout across the back valve cover.  You can also tee into that for a vacuum/boost gauge.  My engine fully warm makes a full 20" of vacuum even in gear at times, and i have 167,000 miles on it. A 95 may need a different connection, not sure.

_________________
98 Riviera SC3800  All stock except gutted air box.
1970 Buick GS455 Stage1, TSP built 470BBB, 602HP/589TQ
Best MPH, 116.06 MPH, Best ET, 11.54
https://www.youtube.com/watch?v=UHCda-t_Jls
https://www.youtube.com/watch?v=sfT2tEO4XcU
Back to top Go down
SpiralArchitect
Rookie


Name : Jesse
Joined : 2016-04-01
Post Count : 12
Merit : 0

High idle, no check engine light Empty
PostSubject: Re: High idle, no check engine light   High idle, no check engine light EmptyFri Jun 24, 2016 4:37 pm

Thanks!...I really appreciate all the helpful suggestions (keep em' coming...lol), sooner or later I'll get the bugs worked out of this thing.....(I hope!!!).
Back to top Go down
Sponsored content




High idle, no check engine light Empty
PostSubject: Re: High idle, no check engine light   High idle, no check engine light Empty

Back to top Go down
 
High idle, no check engine light
Back to top 
Page 1 of 1
 Similar topics
-
» Check Engine light jus came on ?? Help !!
» RZR Problems
» Temp light on when engine is cold??
» Temp light keeps coming on
» How do I check if I'm getting spark?

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   Supercharged 3800 Tech :: Series I Engine & Transmission-
Jump to: