HomeDashboardFAQSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksMemberlistLog in

Share | 
 

 Ugly noise

View previous topic View next topic Go down 
AuthorMessage
ewolfe0050
Aficionado
avatar

Name : Eric
Location : Indianapolis, IN
Joined : 2007-07-31
Post Count : 1159
Merit : 27

PostSubject: Ugly noise   Sun Dec 30, 2007 11:25 pm

I have started hearing a noise when I turn and feeling a clunk going over a bump (curb). The turning noise sounds like my Firebird did when it ran out of powersteering fluid but the Riv is full. Everything has been replaced in the suspension system except for the steering rack. It is a wheezing noise when I turn the wheel. When I replaced the mount and bearing (both OEM) it was slightly greased but I did not grease anymore.

These are my thoughts;
Clunks are coming from Eibach springs hitting inside of upper strut mount perches. I have seen a little rubbing. Easy fix by hammering out a little room.
Strut mount bearings need to be greased more (maybe replaced now).

What are your thoughts??

BTY... mountianrider... did you get new springs yet???
Back to top Go down
mountainrider
Amateur


Joined : 2007-12-02
Post Count : 27
Merit : 0

PostSubject: Re: Ugly noise   Mon Dec 31, 2007 5:12 am

My car is at a friends shop waiting on parts...which I have not yet ordered. I will have an easier time getting hold of people after the first of the year. Springs are deffinitely on the list.

I thought that my steering rack might be a gonner and took it to an alignment shop to have checked out. It was groaning on hard turns. The tech claims that the right front hub is toast along with both inner tie rods. I am having that verified by my pal before ordering anything. Could this be the source of your noise too?

I replaced one tie rod end within the last 20k. Do these cars have an appetite for them?
Back to top Go down
ewolfe0050
Aficionado
avatar

Name : Eric
Location : Indianapolis, IN
Joined : 2007-07-31
Post Count : 1159
Merit : 27

PostSubject: Re: Ugly noise   Mon Dec 31, 2007 9:28 am

Tie rod ends seemed fine when I replaced everything. Is there some way to check them easily or do I need to remove from the spindle to check? How about the hub? I have had other cars the hubs went out on but it seemed to me that it was easy to identify when it did go out.
Back to top Go down
Sponsored content




PostSubject: Re: Ugly noise   

Back to top Go down
 
Ugly noise
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» ae86 rear road noise
» FAQ: Supercharger Noise (Bad Coupler)
» AE82 driving noise?
» alternator noise
» Alternator Noise (mechanical failure)

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   General Tech :: Brakes & Suspension-
Jump to: