HomeDashboardFAQSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksMemberlistLog in

Share | 
 

 My engine woes

View previous topic View next topic Go down 
AuthorMessage
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: My engine woes   Tue Nov 18, 2008 6:01 pm

Ok, from my thread in the "showroom" section:

I did get the plug wires and battery in tonight. I got it to start! Yay!

The noise it makes is something ferocious though... Im not sure WTH it is but it doest sound good.

It has a loud like cackle and it idles wonderful? Whatever it is its in front in the heads to the left *I think*...

Going to try and have a mechanic look at it tomorrow to get an idea. Normally I do all my own work as I can (if I know whats wrong!) but being its cold out I might just let the shop do this one. If its not worth repairing I will just do a motor swap.

Bottom like is if I can repair it by dropping the oil pan or through the valve cover I will do it. If I gotta pull the head off- then I will just swap motors. The head gaskets and Intake gaskets are pricey IMO.

BTW the car has almost 119K on it. And yes everythign seems to work but the radio- which Im replacing anyhow.

I inspected the Harmonic Balancer tonight and its perfect.

The Mechanic came over and had a listen. Within 30 seconds I am told he suggested it was spun rod bearing(s).

Tomorrow first thing Im going to find a garage to work in. Then Im going to check the flex plate first off. Failing that Im going to jump into the rod bearings and replace the oil gasket.

Yippeeeee!!!!!!
Back to top Go down
vendetta
Enthusiast
avatar

Name : Nick
Age : 108
Location : Shakopee, MN
Joined : 2008-09-26
Post Count : 219
Merit : 0

PostSubject: Re: My engine woes   Tue Nov 18, 2008 6:18 pm

sounds like boat loads of fun
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Tue Nov 18, 2008 8:14 pm

Ordered rod bearings tonight so they will be in tomorrow.

I was at Advance and went to get the oil pan gasket. Online they quote it at $50.99 and a cheaper one at $43.99

Went to the store and the only one "he can get" is $59.99. Im like WTH it says $50.99 online with free in store pickup... He replied "Its $59.99" I said forget it. Guess I will just order it online for $8 less and pick it up in the morning :p

I hate Advance Auto. They are thieves!
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Tue Nov 18, 2008 8:15 pm

Oh snap I put this in the S/C forum. Im N/A...

Mods can you please move this thread?
Back to top Go down
98riv
Moderator


Location : USA
Joined : 2007-01-14
Post Count : 953
Merit : 30

PostSubject: Re: My engine woes   Tue Nov 18, 2008 8:52 pm

Moved the thread for you.

_________________
1998 Supercharged Riviera - Custom CAI, Alpine spx-13ref, Infinity 6x9's, Alpine 4 Channel Amp, Kicker KX3, Silverstars, STB, Hawk Brake Pads, Monroe Air Shocks, KYB GR2
Back to top Go down
1998 Riv
Expert
avatar

Name : Dave
Age : 57
Location : In The AZ Oven
Joined : 2007-01-17
Post Count : 4502
Merit : 44

PostSubject: Re: My engine woes   Tue Nov 18, 2008 9:22 pm

If I'm going to buy from Advance, I look up their online price, print off a copy, and take it with me to the store. They've always matched the partsamerica online pricing, but usually have had to order the parts.
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Tue Nov 18, 2008 9:51 pm

Well Im just going to order it from Rock Auto.

Under $40 shipped...
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Wed Nov 19, 2008 11:25 am

Welp I got under the car this morning. After 1 Hr 20 minutes (I work slow) I got the plugs out and the oil pan off. Oh ya its a spun rod bearing. I dont even think theres a fricking bearing in it- its that loose. I need to find a 7/16" 6 popint socket and some lunch before I continue. At this rate should be done by about dark. Let the silicone setup oer night oil and start tomorrow.

Thats IF I can get the rod bearing in/on through the bottom like I hope. At least this isnt a Split-Pin crankshaft!
Back to top Go down
albertj
Guru
avatar

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 6752
Merit : 124

PostSubject: Re: My engine woes   Wed Nov 19, 2008 12:52 pm

That's unusual. How do you think it got spun?

Albertj
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Wed Nov 19, 2008 1:21 pm

Ackkkkkkk it IS a split pin crank.

I got 2 rod bearings spun/gone I took one off. The crank has some nice ridges in it....

Who knows how it got spun. All I can tell you is theres generous play in 2 of the 6. The bearing material was "squeezed" out to the sides. Also theres some nice ridges in the crank.
Back to top Go down
albertj
Guru
avatar

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 6752
Merit : 124

PostSubject: Re: My engine woes   Wed Nov 19, 2008 1:38 pm

sorry about that.

Albertj
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Wed Nov 19, 2008 1:44 pm

Well when I got this car I was prepared to do the motor swap. So this isnt a big surprise. I was just hoping I could be cheap and get away with a fix.
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Sun Nov 23, 2008 9:35 pm

This section is dead.

I guess that happens when this car mainly had supercharges on them...lol

Anyhow I got the engine yanked out tonight. Took a total of about 8 hours to get it on the ground.
Back to top Go down
deekster_caddy
Master


Name : Derek
Age : 45
Location : Reading, MA
Joined : 2007-01-31
Post Count : 7716
Merit : 109

PostSubject: Re: My engine woes   Mon Nov 24, 2008 3:32 pm

Just that not many N/A 3800s having problems or modded... Not a dead section!

8 hrs not bad to pull this sucker out.
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Mon Nov 24, 2008 3:34 pm

And another update.

Im picking a motor up Tuesday night for this baby. its from an 05 Impala with 41K on it. Got a hell of a deal (I hope).

Hopefully will be on the road this weekend.
Back to top Go down
AA
Administrator
avatar

Name : Aaron
Age : 40
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18310
Merit : 239

PostSubject: Re: My engine woes   Mon Nov 24, 2008 3:38 pm

Yes, please post up anything you have, Ryan. The next N/A member will surely appreciate it!

_________________
'98 SC Riviera 268k miles 298 HP/370 TQ 0-60: 5.79s ET: 13.97 @ 99.28 4087 lb 20.1 avg MPG Nelson Ledges Lap: 1:30
3.4" pulley AL104 plugs 180 t-stat FWI w/K&N 1.9:1 rockers OR pushrods LS6 valve springs SLP headers ZZP fuel rails
KYB GR2 struts MaxAir shocks Addco sway bars UMI bushings GM STB Enkei 18" EV5s w/ Dunlop DZ101s F-body calipers
EBC bluestuff/Hawk HP plus SS lines Brembo slotted discs DHP tuned Aeroforce Hidden Hitch


'05 GTO 49k miles 0-60: 4.8s 16.9 avg MPG Nelson Ledges Lap: 1:26
Because fun
Back to top Go down
http://www.cardomain.com/ride/657082/4
'96reese
Fanatic


Name : Reese
Age : 35
Location : StL
Joined : 2007-09-20
Post Count : 259
Merit : 4

PostSubject: Re: My engine woes   Mon Nov 24, 2008 7:22 pm

ryan you should go to zzperformance and buy the parts to build up the old motor! jus an idea, 300hp @ the wheels doesnt hurt........
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Tue Nov 25, 2008 9:12 am

AA I will get some pictures tonight.

The hardest part of getting this motor out is the reversed bolt going from passenger side to drivers side where as the other 5 bolts are right there in plain sight!

Theres some bracketry thats a big PITA also. But nothing you cant over come with some patience.

I see these motor swaps as a puzzle and enjoy the challenge. I tend to have a bad memory but for some odd reason I excel at doing things like this...
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Wed Nov 26, 2008 9:55 pm

Well I havent been around much working on the Riviera.







New motor. its from an 05 Impala with 41K on it. Basically the fuel injectors and ALL sensores have different plugs so they all need to be swapped out. Also the alternator... Grrr....



Another shot of the new motor!
Back to top Go down
deekster_caddy
Master


Name : Derek
Age : 45
Location : Reading, MA
Joined : 2007-01-31
Post Count : 7716
Merit : 109

PostSubject: Re: My engine woes   Thu Nov 27, 2008 7:15 am

I'm surprised about the injectors, but not about the alternator. The alternators ad bracketry is so different from car to car. Good work so far!
Back to top Go down
Ryan from Ohio
Fanatic


Name : Ryan
Location : Toledo, Ohio
Joined : 2008-11-16
Post Count : 307
Merit : 7

PostSubject: Re: My engine woes   Sun Nov 30, 2008 8:58 pm

Well its done and running!

This car drives like a dream...

The water outlets is modular and I was able to swap them out without to much hassle. A total oversight as you can tell by my other post...lol

Power steerings a bit noisy I think it got some air in it. Will bleed it tomorrow.

The brakes are messed probably because it sat for an unkown amount of time. Rusted up.

I got one hose that split when I put it on. Its a rubber connector type, so just some new hose should do the trick.

Now the last issue. The check engine lights on AND the traction control light.

Buttom up with the fancy plastic shield up top and done.
Back to top Go down
Rickw
Guru


Name : Rick
Age : 59
Location : Lancaster, MA
Joined : 2008-09-13
Post Count : 6081
Merit : 105

PostSubject: Re: My engine woes   Sun Nov 30, 2008 9:03 pm

You will need to hook up a scan tool and check everything out, look at codes, make certain all systems are working correctly, then clear codes.
Relatively quick swap and you got a nice low mileage motor.
Congrats and good luck.
Back to top Go down
KillaKeninaRiv
Addict
avatar

Name : Kenneth
Age : 35
Location : Roseville, MI
Joined : 2008-05-17
Post Count : 709
Merit : 6

PostSubject: Re: My engine woes   Fri Dec 26, 2008 2:22 am

yeah my motor had the same problem with the different injectors. i didnt know that other models with 3800s used different injectors. i found out when the car kept driving like crap, used the original injectors and it was like new.
Back to top Go down
Sponsored content




PostSubject: Re: My engine woes   

Back to top Go down
 
My engine woes
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» My engine woes
» Service Honda, XR650R engine in a CRF450X like your CR500AFX
» K100RS Injection woes
» LS Engine sourcing
» RCGF 45cc Petrol Engine

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   N/A 3800 Tech :: Series II N/A Engine, Transmission, PCM-
Jump to: