The 8th Gen Riviera Resource
 
HomeDashboardSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

Share
 

 95RiviSC's Problem Thread

Go down 
Go to page : Previous  1, 2, 3, 4, 5  Next
AuthorMessage
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptySat Aug 15, 2009 12:41 am

^^You know that might be it. I'll have to take a look at that tomorrow.
Back to top Go down
http://www.clublakers.com
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyWed Aug 19, 2009 11:47 pm

One quick question for you guys. About 3 months ago (roughly) I used a fuel additive called 44k. Would I be able to clean out the fuel injectors? Some guy was telling me that it's a bad idea, since I had used the fuel additive.
Back to top Go down
http://www.clublakers.com
AA
Administrator
AA

Name : Aaron
Age : 42
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18370
Merit : 241

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyThu Aug 20, 2009 9:18 am

It's just a fuel system cleaner. I use a similar product (Techron) about every 3-5k miles. It's a good idea to clean your injectors.

_________________
'98 SC Riviera • 281k miles • 298 HP/370 TQ • 0-60: 5.79s • ET: 13.97 @ 99.28 • 4087 lb • 20.1 avg MPG • Nelson Ledges Lap: 1:30
3.4" pulley • AL104 plugs • 180º t-stat • FWI w/K&N • 1.9:1 rockers • OR pushrods • LS6 valve springs • SLP headers • ZZP fuel rails
KYB GR2 struts • MaxAir shocks • Addco sway bars • UMI bushings • GM STB • Enkei 18" EV5s w/ Dunlop DZ101s • F-body calipers
EBC bluestuff/Hawk HP plus • SS lines • Brembo slotted discs • DHP tuned • Aeroforce • Hidden Hitch

^^^ SOLD ^^^ frown

'05 GTO • 85k miles • 0-60: 4.8s • 16.9 avg MPG • Nelson Ledges Lap: 1:26
Because fun


'70 Olds Ninety-Eight Holiday Coupe • 116k miles • 455 Rocket V8
Because cool


'95 Celica • 152k miles • 0-60: yes
Because free
Back to top Go down
http://www.cardomain.com/ride/657082/4
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyThu Aug 20, 2009 3:22 pm

AA wrote:
It's just a fuel system cleaner. I use a similar product (Techron) about every 3-5k miles. It's a good idea to clean your injectors.
Alright, thanks man. He was telling me that I should only be using the fuel additive no more than once a year because it could be harmful to the car.

But, I'll get the injectors cleaned out this weekend.
Back to top Go down
http://www.clublakers.com
albertj
Master
albertj

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 7580
Merit : 154

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyThu Aug 20, 2009 3:52 pm

Techron could be used every 3-5K (I use it at least every other oil change) but other fuel additives maybe not.

Albertj
Back to top Go down
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyThu Sep 10, 2009 2:00 am

After doing all this maintenance on the vehicle, the stuttering(for lack of a better term) seems to have subsided. It was getting to the point where it would do it every single day at the same exact speeds.

Now, no problem with it. It did do it a little a few weeks ago but it hasn't since.

My only thing right now is that it seems to be kind of shaky. The plugs and cables have been replaced. Thoughts?
Back to top Go down
http://www.clublakers.com
robotennis61
Guru
robotennis61

Name : robotennis
Age : 58
Location : las vegas
Joined : 2007-12-17
Post Count : 5561
Merit : 142

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyThu Sep 10, 2009 2:40 am

check the coils?
Back to top Go down
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyThu Sep 10, 2009 4:10 pm

robotennis61 wrote:
check the coils?
How do I go about doing that?
Back to top Go down
http://www.clublakers.com
robotennis61
Guru
robotennis61

Name : robotennis
Age : 58
Location : las vegas
Joined : 2007-12-17
Post Count : 5561
Merit : 142

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyThu Sep 10, 2009 8:49 pm

start the car. starting from the top wire on the coil pack. with engine running remove one wire at a time and hold the wire closely to the coil, watch the spark if its weak that is an indication that the coil is failing. do each wire till you test them all. if one of the terminals is bad you wont see an arc. my top coil pack was in a intermitent failure and i located it this way. go to the auto store and buy a "plastic" wire puller. they are yellow. this will keep your hands from getting buzzed. if your tough and can take pain without meowling you dont need it. while your doing this keep your hands away from moving parts.
Back to top Go down
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 12:09 am

The car seems to be shifting kind of hard. It only does it when I've been driving for a while, 45min-1hr. You can really feel it after you come to a stop then accelerate. It does it around 20-30MPH.

Is this a cause for concern?
Back to top Go down
http://www.clublakers.com
robotennis61
Guru
robotennis61

Name : robotennis
Age : 58
Location : las vegas
Joined : 2007-12-17
Post Count : 5561
Merit : 142

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 12:20 am

did u check the coils. have u changed the tranny fluid and filter?
Back to top Go down
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 12:24 am

robotennis61 wrote:
did u check the coils. have u changed the tranny fluid and filter?
I did check the coils and they were fine.

I don't know how it happened, but one of the plug wires on the backside of the engine was cut, so I replaced that.

As far as the tranny fluid and filter, they were both changed about 2 months ago.
Back to top Go down
http://www.clublakers.com
L67
Aficionado


Name : Matt
Joined : 2007-06-05
Post Count : 1125
Merit : 37

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 1:12 am

95RiviSC wrote:
robotennis61 wrote:
did u check the coils. have u changed the tranny fluid and filter?
I did check the coils and they were fine.

I don't know how it happened, but one of the plug wires on the backside of the engine was cut, so I replaced that.

As far as the tranny fluid and filter, they were both changed about 2 months ago.

It may be the vacuum control modulator which is on the trans in the area beneath the throttle body. It's pretty cheap to buy and has a screw to adjust the shift harshness.
Back to top Go down
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 1:19 am

^^Can that modulator be tested?
Back to top Go down
http://www.clublakers.com
L67
Aficionado


Name : Matt
Joined : 2007-06-05
Post Count : 1125
Merit : 37

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 1:21 am

95RiviSC wrote:
^^Can that modulator be tested?

I'm not sure but it's only like $10 so even if it doesn't necessarily solve the problem you won't lose much money.
Back to top Go down
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 1:26 am

Back to top Go down
http://www.clublakers.com
L67
Aficionado


Name : Matt
Joined : 2007-06-05
Post Count : 1125
Merit : 37

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 1:27 am

95RiviSC wrote:
Transmission Modulator Valve

Is that it?

Looks right, there's no picture showing but it seems to be the right price.
Back to top Go down
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 1:46 am

I did a little Google search and it says that when that Modulator goes bad, it typically comes with white smoke. I haven't gotten any smoke. Just a rough shift from idle.
Back to top Go down
http://www.clublakers.com
L67
Aficionado


Name : Matt
Joined : 2007-06-05
Post Count : 1125
Merit : 37

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 1:59 am

95RiviSC wrote:
I did a little Google search and it says that when that Modulator goes bad, it typically comes with white smoke. I haven't gotten any smoke. Just a rough shift from idle.

Well other 4T60 trans owners on here (myself included) have purchased this part with great success. It's only $13.... The rough shifting might also be from a loose vac line to the trans as well. You can check that out as well.
Back to top Go down
deekster_caddy
Master


Name : Derek
Age : 47
Location : Reading, MA
Joined : 2007-01-31
Post Count : 7717
Merit : 109

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 12:52 pm

Yes. It could be a TPS or the like, that exact same thing happened to my '94 Regal 3800 and it was TPS. Do you have a check engine light?
Back to top Go down
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 2:13 pm

deekster_caddy wrote:
Yes. It could be a TPS or the like, that exact same thing happened to my '94 Regal 3800 and it was TPS. Do you have a check engine light?

I didn't have a check engine light for about 3-4 weeks, until today.

I took her out for a drive and she started shuddering around 50MPH. The light came on right after. I don't have any cash to get the codes read and the Auto Zones by my place don't have the OBD scanner that I need .

It's starting to get kind of overwhelming at this point. I barely have enough money to get by and then stuff like this starts to happen, again.
Back to top Go down
http://www.clublakers.com
woggy
Enthusiast
woggy

Name : Paul
Age : 58
Location : Altoona, Florida (Somewhere in the ocala national forest)
Joined : 2009-04-28
Post Count : 201
Merit : 7

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 2:38 pm

id bet that the tps is bad.
just bring your riv here and ill scan it and help you fix it for nothing.
Back to top Go down
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 2:59 pm

woggy wrote:
id bet that the tps is bad.
just bring your riv here and ill scan it and help you fix it for nothing.
Money is kind of tight right now (sadly). But I will try to get that replaced soon.

As far as your offer, I'd love to take it there, but unfortunately you are about 1600 miles too far, lol.
Back to top Go down
http://www.clublakers.com
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 3:06 pm

I don't know if this helps, but there was a weird noise coming from around the SC area. This was while the car was turned off. I recorded a short video of it, I'll try to upload it when I can.
Back to top Go down
http://www.clublakers.com
95RiviSC
Member
95RiviSC

Name : Jose
Age : 30
Joined : 2009-06-29
Post Count : 87
Merit : 0

95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 EmptyFri Sep 18, 2009 3:19 pm

Also, when I was at a red light the RPM needle would go up and down, but only between the 0 and the 1.
Back to top Go down
http://www.clublakers.com
Sponsored content




95RiviSC's Problem Thread - Page 3 Empty
PostSubject: Re: 95RiviSC's Problem Thread   95RiviSC's Problem Thread - Page 3 Empty

Back to top Go down
 
95RiviSC's Problem Thread
Back to top 
Page 3 of 5Go to page : Previous  1, 2, 3, 4, 5  Next
 Similar topics
-
» Custom Chassis Build Thread
» The Costume Thread....
» Eye Candy thread removed!
» Global RC 50cc Raven - Assembly Thread - Pic Heavy
» Homemade Thread ( if it cost to much so you made it yourself, please show it off here!)

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   Supercharged 3800 Tech :: Series I Engine & Transmission-
Jump to: