HomeDashboardFAQSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksMemberlistLog in

Share | 
 

 something with traction control

View previous topic View next topic Go down 
AuthorMessage
brmcm15
Member
avatar

Name : Brandon
Age : 26
Location : Macomb, Michigan
Joined : 2008-12-02
Post Count : 84
Merit : 0

PostSubject: something with traction control   Sat Jul 11, 2009 12:05 am

ok guys for the past few weeks my riviera has made this wired noise when i am reversing and sometimes when im taking off. it locks up my brakes until i push them down a little then it goes away for a little and then comes back. i have no idea what the problem is, i was thinking it might have something to do with the traction control because right when i turn the car on and the traction control off there is no noise and the brakes dont lock up at all. it would be great if you guys could help me find out what the problem is.








thanks, Brandon
Back to top Go down
ewolfe0050
Aficionado
avatar

Name : Eric
Location : Indianapolis, IN
Joined : 2007-07-31
Post Count : 1159
Merit : 27

PostSubject: Re: something with traction control   Sat Jul 11, 2009 12:54 am

You have a bad hub.
Back to top Go down
brmcm15
Member
avatar

Name : Brandon
Age : 26
Location : Macomb, Michigan
Joined : 2008-12-02
Post Count : 84
Merit : 0

PostSubject: Re: something with traction control   Sat Jul 11, 2009 2:35 am

Oh ok. Thanks.
Back to top Go down
Snowdog
Addict
avatar

Name : Timo
Age : 31
Location : Finland
Joined : 2008-10-04
Post Count : 730
Merit : 22

PostSubject: Re: something with traction control   Sat Jul 11, 2009 7:12 am

reversing?

where exactly dos the sound come? from front or back of the car?
are the brakes making a noise?
well mine did some squeeking noise sometimes on reversing..
found out later that the rear brake callibers one side was stuck..so when it braked the calibre pressed the brake bads sideways against the rootors that made the bads wear only from one side so they where weared on angle..
had to take the calibers off and clean the sliding parts.
and replace new bads...after that the problem was solved.

but also can be the hub like Eric ementioned.

could help more if u descrive the noise...and where it exactly comes..
Back to top Go down
deekster_caddy
Master


Name : Derek
Age : 45
Location : Reading, MA
Joined : 2007-01-31
Post Count : 7716
Merit : 109

PostSubject: Re: something with traction control   Sat Jul 11, 2009 7:22 am

Sounds like a bad wheel speed sensor (hub).
Back to top Go down
Sponsored content




PostSubject: Re: something with traction control   

Back to top Go down
 
something with traction control
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Traction Control???
» Help...No Brake Lights or Traction Control!!
» Traction Control Brakes for those of us without ABS
» Traction control off all of the time
» Traction Control module

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   General Tech :: Brakes & Suspension-
Jump to: