The 8th Gen Riviera Resource
 
HomeDashboardSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

Share
 

 Temp guage issue......1995 Riv 3800 series 1 SC

Go down 
AuthorMessage
designer1962
Enthusiast
designer1962

Name : Harvey
Age : 76
Location : Baltimore, MD
Joined : 2011-05-29
Post Count : 105
Merit : 0

Temp guage issue......1995 Riv 3800 series 1 SC Empty
PostSubject: Temp guage issue......1995 Riv 3800 series 1 SC   Temp guage issue......1995 Riv 3800 series 1 SC EmptyMon Jun 06, 2011 7:09 pm

Upon start the temp guage will appear to rise as normal. After a few minutes it will swing all the way into max hot area. In a few moments, it will drop all the way back to start position and the check engine light then comes on. The car does not overheat and seems to be running at normal temperature. I replaced the coolant temp sensor and it had no effect. I just replaced the engine with a remanufctured one and it continues the same issue with the guage as it did with the old engine. The mechanic who installed the engine noticed that the cooling fan runs as soon as the car starts (I don't know if this is normal)

Anyone have any ideas what is going on here? Relay? Sensor? Computer? Ghost? Any help would be appreciated.



Back to top Go down
robotennis61
Guru
robotennis61

Name : robotennis
Age : 58
Location : las vegas
Joined : 2007-12-17
Post Count : 5561
Merit : 142

Temp guage issue......1995 Riv 3800 series 1 SC Empty
PostSubject: Re: Temp guage issue......1995 Riv 3800 series 1 SC   Temp guage issue......1995 Riv 3800 series 1 SC EmptyMon Jun 06, 2011 7:18 pm

Ghost.I have the same issue.It was suggested to me that I take apart the dash.I have not done so yet.You be the first.
Back to top Go down
jlaw
Member
jlaw

Name : Jay
Location : Vancouver Island, Canada
Joined : 2011-04-19
Post Count : 70
Merit : 2

Temp guage issue......1995 Riv 3800 series 1 SC Empty
PostSubject: Re: Temp guage issue......1995 Riv 3800 series 1 SC   Temp guage issue......1995 Riv 3800 series 1 SC EmptyMon Jun 06, 2011 7:27 pm

Since you've obviously eliminated any issues related to the engine itself or sensors on the engine, I would look to the wiring between the sensor (I guess you can probably start wherever the harness connects to the new motor) and the gauge, looking for anywhere the wire could be stripped or corroded or otherwise grounding to something else. This very well may involve pulling the dash apart. I had an oil pressure gauge on a Toyota do something similar and it turned out to be a corroded connector at a harness link (after replacing the sending unit and checking fuses and relays of course).
Back to top Go down
Sponsored content




Temp guage issue......1995 Riv 3800 series 1 SC Empty
PostSubject: Re: Temp guage issue......1995 Riv 3800 series 1 SC   Temp guage issue......1995 Riv 3800 series 1 SC Empty

Back to top Go down
 
Temp guage issue......1995 Riv 3800 series 1 SC
Back to top 
Page 1 of 1
 Similar topics
-
» INTERNATIONAL SERIS PLAYER ISSUE SAINTS JERSEY FOR SALE
» Briggs And stratton 900 Series I/c ohv
» ARM WARS SUPER SERIES HITS GERMANY IN APRIL 2011
» Lucas Oil Off Road Racing Series Short Course---USTREAM TV Live
» Danica Patrick SI Swimsuit Issue

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   Supercharged 3800 Tech :: Series I Engine & Transmission-
Jump to: