The 8th Gen Riviera Resource
 
HomeDashboardSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

Share
 

 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)

Go down 
AuthorMessage
oldmanriver
Member


Name : oldmanriver
Location : Pittsburgh, PA
Joined : 2012-07-29
Post Count : 74
Merit : 1

95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) EmptySun Jul 29, 2012 11:00 pm

I will have to start the Riv two to three times listen to it struggle to idle. When it does its smooth, but very hesitant when I get on the gas. I don't hear the SC whine and it seems to struggle for air. I have everything I can third of from where I stand, what I know, and some help. No check engine light. No codes. Just runs like shit!!

Any help/feedback would be appreciated, thanks. OMR
Back to top Go down
th3fr4nchi5e
Addict
th3fr4nchi5e

Name : Dave
Age : 26
Location : Cheektowaga, NY (Buffalo)
Joined : 2010-10-31
Post Count : 540
Merit : 23

95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: Re: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) EmptySun Jul 29, 2012 11:22 pm

Welcome! the SC whine isnt always noticable with the stock air box. Symptoms sound like bad fuel pump maybe? also, the cars exhaust sounds like the car is struggling for air at low revs once the Catalytic Converter wears out. The cars mileage may help someone here diagnose it?
Back to top Go down
oldmanriver
Member


Name : oldmanriver
Location : Pittsburgh, PA
Joined : 2012-07-29
Post Count : 74
Merit : 1

95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: Re: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) EmptyMon Jul 30, 2012 7:53 am

125k mi I used to be able to hear and feel when the SCSI would do its job, but nothing now. I don't know if its the SC or something from preventing it to work. I have to feather the gas to get around... Forget about gettin on it to downshift or climb a hill
Back to top Go down
pbrktrt
Enthusiast


Name : patrick gervais
Location : muskegon.mi
Joined : 2011-07-18
Post Count : 164
Merit : 5

95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: Re: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) EmptyMon Jul 30, 2012 7:35 pm

When's the last time you changed the fuel filter? Have you checked rail pressure? It sounds like it's starving for fuel.
Back to top Go down
oldmanriver
Member


Name : oldmanriver
Location : Pittsburgh, PA
Joined : 2012-07-29
Post Count : 74
Merit : 1

95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: Re: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) EmptyMon Jul 30, 2012 11:05 pm

haven't change the fuel filter but got good pressure @ the rail. Wires are good new plugs, had a buddy do all he could, by checking all he could regarding electrical systems with a voltmeeter and seeing if the output was correct per component. He recommends a mapscope because he found nothing abnormal and no check engine light. I need some help from the Rivi forum to help save me the $ I don't have. College tuition gotta come first, I will ONLY ride the bus if I have to!! I want the Riv back to the hitch she used to be
Back to top Go down
AA
Administrator
AA

Name : Aaron
Age : 42
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18369
Merit : 241

95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: Re: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) EmptyTue Jul 31, 2012 12:49 am

When you say "wires are good", you mean they've been replaced with brand new, genuine AC Delco wires, right?

_________________
'98 SC Riviera • 281k miles • 298 HP/370 TQ • 0-60: 5.79s • ET: 13.97 @ 99.28 • 4087 lb • 20.1 avg MPG • Nelson Ledges Lap: 1:30
3.4" pulley • AL104 plugs • 180º t-stat • FWI w/K&N • 1.9:1 rockers • OR pushrods • LS6 valve springs • SLP headers • ZZP fuel rails
KYB GR2 struts • MaxAir shocks • Addco sway bars • UMI bushings • GM STB • Enkei 18" EV5s w/ Dunlop DZ101s • F-body calipers
EBC bluestuff/Hawk HP plus • SS lines • Brembo slotted discs • DHP tuned • Aeroforce • Hidden Hitch

^^^ SOLD ^^^ frown

'05 GTO • 85k miles • 0-60: 4.8s • 16.9 avg MPG • Nelson Ledges Lap: 1:26
Because fun


'70 Olds Ninety-Eight Holiday Coupe • 116k miles • 455 Rocket V8
Because cool


'95 Celica • 152k miles • 0-60: yes
Because free
Back to top Go down
http://www.cardomain.com/ride/657082/4
oldmanriver
Member


Name : oldmanriver
Location : Pittsburgh, PA
Joined : 2012-07-29
Post Count : 74
Merit : 1

95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: Re: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) EmptyTue Jul 31, 2012 10:32 am

No. A mechanic friend said they were, so I took his word. I have had spark related problems in the past, this doesn't seem to be a spark issue.
Back to top Go down
AA
Administrator
AA

Name : Aaron
Age : 42
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18369
Merit : 241

95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: Re: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) EmptyTue Jul 31, 2012 10:37 am

Just my .02. If your engine has close to 100k miles, and you don't know when the last time the wires were changed - and you plan fix the problem and drive this car in the future - I'd drop $35 and order some new GM wires. It's just a good thing to do for maintenance purposes, even if it's not causing the problem.

When my first set of wires failed, they looked 100% perfect. I still don't know which one went bad. And I don't care - my problem disappeared, so I was happy!

_________________
'98 SC Riviera • 281k miles • 298 HP/370 TQ • 0-60: 5.79s • ET: 13.97 @ 99.28 • 4087 lb • 20.1 avg MPG • Nelson Ledges Lap: 1:30
3.4" pulley • AL104 plugs • 180º t-stat • FWI w/K&N • 1.9:1 rockers • OR pushrods • LS6 valve springs • SLP headers • ZZP fuel rails
KYB GR2 struts • MaxAir shocks • Addco sway bars • UMI bushings • GM STB • Enkei 18" EV5s w/ Dunlop DZ101s • F-body calipers
EBC bluestuff/Hawk HP plus • SS lines • Brembo slotted discs • DHP tuned • Aeroforce • Hidden Hitch

^^^ SOLD ^^^ frown

'05 GTO • 85k miles • 0-60: 4.8s • 16.9 avg MPG • Nelson Ledges Lap: 1:26
Because fun


'70 Olds Ninety-Eight Holiday Coupe • 116k miles • 455 Rocket V8
Because cool


'95 Celica • 152k miles • 0-60: yes
Because free
Back to top Go down
http://www.cardomain.com/ride/657082/4
oldmanriver
Member


Name : oldmanriver
Location : Pittsburgh, PA
Joined : 2012-07-29
Post Count : 74
Merit : 1

95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: Re: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) EmptyTue Jul 31, 2012 12:22 pm

Good advice. I plan on keeping it and when I get shit in order I plan on doing a lot of work in it. Always loved the The Rivs
Back to top Go down
96riv
Fanatic
96riv

Name : Dennis
Location : Phoenix
Joined : 2007-03-08
Post Count : 378
Merit : 7

95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: Re: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) EmptyTue Jul 31, 2012 3:20 pm

Ohm your plug wires to find out if they are bad. I have found bad wires this way.
Back to top Go down
http://www.arizonagn.com
Sponsored content




95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty
PostSubject: Re: 95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)   95 sc Riv.... starts the dies... no power...hesitant... hard (hot start) Empty

Back to top Go down
 
95 sc Riv.... starts the dies... no power...hesitant... hard (hot start)
Back to top 
Page 1 of 1
 Similar topics
-
» 15.5 hp turbo cooled craftsman briggs and stratton wont start
» 8.5 hp Briggs Snoblower Surges then Dies
» Power Mods ????
» power chips or modules
» Power Plays

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   Supercharged 3800 Tech :: Series I Engine & Transmission-
Jump to: