HomeDashboardFAQSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksMemberlistLog in

Share | 
 

 She don't die, she just bogs down

View previous topic View next topic Go down 
AuthorMessage
JLA
Newbie


Name : JeffysRivey
Age : 58
Location : So Cal
Joined : 2012-08-17
Post Count : 2
Merit : 0

PostSubject: She don't die, she just bogs down   Fri Aug 17, 2012 7:21 pm

I love this car, had it 9 years now...95 3800 Series II non sc
After driving 5-10 miles the rpm's drop and the car wont go over 10 -15 mph.....
After cooling down 2-3 hours she takes off again.....help
Back to top Go down
AA
Administrator
avatar

Name : Aaron
Age : 40
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18310
Merit : 239

PostSubject: Re: She don't die, she just bogs down   Fri Aug 17, 2012 9:24 pm

Hmm. If you'd said RPMs go up... I'd suspect transmission. Any lamps on in the dash?

_________________
'98 SC Riviera 268k miles 298 HP/370 TQ 0-60: 5.79s ET: 13.97 @ 99.28 4087 lb 20.1 avg MPG Nelson Ledges Lap: 1:30
3.4" pulley AL104 plugs 180 t-stat FWI w/K&N 1.9:1 rockers OR pushrods LS6 valve springs SLP headers ZZP fuel rails
KYB GR2 struts MaxAir shocks Addco sway bars UMI bushings GM STB Enkei 18" EV5s w/ Dunlop DZ101s F-body calipers
EBC bluestuff/Hawk HP plus SS lines Brembo slotted discs DHP tuned Aeroforce Hidden Hitch


'05 GTO 49k miles 0-60: 4.8s 16.9 avg MPG Nelson Ledges Lap: 1:26
Because fun
Back to top Go down
http://www.cardomain.com/ride/657082/4
JLA
Newbie


Name : JeffysRivey
Age : 58
Location : So Cal
Joined : 2012-08-17
Post Count : 2
Merit : 0

PostSubject: Re: She don't die, she just bogs down   Sat Aug 18, 2012 12:59 am

Hey...thanks for the reply......service engine soon, does go on....tnans..hmmmm....just put a used tranny in about 5 months ago........when it is running ok , the rpms are a bit erratic....1.8 to 3.0,otherwise when shes losing power the rpm drop to 1.5....now as far as lamps go ...the security lamp and traction control do go off and on from time to time..but have since I've owned the car...and the low coolant light goes off and on....but all systems ok here(just had it completely tested ok and both fans are fully operational)..fuel filter just changed yesterday....complete tune up 6 months ago...just ordered a vacuum hose kit .....will install next week.....cat converter new.....always fires the first time .....no slipping........
Back to top Go down
albertj
Guru
avatar

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 6752
Merit : 124

PostSubject: Re: She don't die, she just bogs down   Sat Aug 18, 2012 1:09 am

JLA wrote:
Hey...thanks for the reply......service engine soon, does go on....tnans..hmmmm....just put a used tranny in about 5 months ago........when it is running ok , the rpms are a bit erratic....1.8 to 3.0,otherwise when shes losing power the rpm drop to 1.5....now as far as lamps go ...the security lamp and traction control do go off and on from time to time..but have since I've owned the car...and the low coolant light goes off and on....but all systems ok here(just had it completely tested ok and both fans are fully operational)..fuel filter just changed yesterday....complete tune up 6 months ago...just ordered a vacuum hose kit .....will install next week.....cat converter new.....always fires the first time .....no slipping........

i suspect combination of transmission woes and deferred maintenance...
Back to top Go down
Sponsored content




PostSubject: Re: She don't die, she just bogs down   

Back to top Go down
 
She don't die, she just bogs down
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» 12hp Briggs bogs down when taken over bumps/ steep grades
» Bogs down when cold?
» Bad Bog at WOT
» 95 Riv Stutters under load Help
» Clarksville TN

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   N/A 3800 Tech :: Series II N/A Engine, Transmission, PCM-
Jump to: