The 8th Gen Riviera Resource
 
HomeDashboardFAQSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksMemberlistLog in
Share | 
 

 don't think I've posted in here yet.

Go down 
AuthorMessage
sniperdude
Fanatic
avatar

Name : Mike
Location : Chicago
Joined : 2012-06-04
Post Count : 250
Merit : 18

PostSubject: don't think I've posted in here yet.   Thu Feb 14, 2013 6:12 pm

Hey all. I have actually been on here for the last 8 months, and I've found this site incredibly helpful since I spent most of that time trying to get this Riv going.

I bought it hoping it would be a quick fixer, but no such luck. haha

So far I've replaced the transmission, belts, starter, engine cradle, fuel filter, brake lines, oil pan gasket, spark plugs, spark plug wires, IACV, lots and lots of coolant hoses, air filter, oil change, etc.

I even ended up getting a whole set of almost-new tires locally (5000mi on em') mounted on OEM wheels (guy's RIv burned up).

I really like the Riv, I only drove it once right after I had the transmission replaced.

Right now I'm chasing down a battery drain issue. Only a bit more and I can finally start using it proper.

I hope you guys have found my contributions helpful, and I'm always up for learning new stuff.

Cheers!

Here's a pic from the field I had it towed from when I bought it. lol
Back to top Go down
 
don't think I've posted in here yet.
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   General :: Showroom-
Jump to: