The 8th Gen Riviera Resource
 
HomeDashboardSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

Share
 

 Riv would not accelerate!

Go down 
AuthorMessage
artlock
Amateur
artlock

Name : Art
Age : 52
Location : PG County MD
Joined : 2011-11-28
Post Count : 36
Merit : 0

Riv would not accelerate!  Empty
PostSubject: Riv would not accelerate!    Riv would not accelerate!  EmptyMon Mar 18, 2013 6:16 pm

I am not sure what to search for this issue so excuse me if it's already posted somewhere. I had just filled my gas tank and pulled out the gas station. My riv cut off at the stop sign as it does every now and then (still looking for that problem.) like normal it started right back up. I put it in drive and hit the gas and nothing. The engine revved and check engine light came on but the car didn't move. I tried it again and I had to rev the engine to a out 3000 rpms for it to move about 10 mph. As I go to pull over, it starts driving normal again. I pulled over and check the codes. The only codes that were present were history codes for quad driver module 4 and p0630 which said low battery voltage. The weird thing is that the cel was still on. So I cleared the codes and the cel turned off and the scanner said no faults. Any ideas what happened?
Back to top Go down
bigdave
Fanatic


Name : Dave
Age : 55
Location : Cheektowaga , NY (Buffalo)
Joined : 2010-10-17
Post Count : 399
Merit : 22

Riv would not accelerate!  Empty
PostSubject: Re: Riv would not accelerate!    Riv would not accelerate!  EmptyMon Mar 18, 2013 6:55 pm

Check your transmission fluid. Your description of what happened indicates a slip of the transmission. Just a place to start. Also check the wiring connections at the tranny.
Back to top Go down
artlock
Amateur
artlock

Name : Art
Age : 52
Location : PG County MD
Joined : 2011-11-28
Post Count : 36
Merit : 0

Riv would not accelerate!  Empty
PostSubject: Re: Riv would not accelerate!    Riv would not accelerate!  EmptyMon Mar 18, 2013 8:06 pm

Thanks! I did check the fluid level and it was right at the add mark. Have not had a chance to check the wiring because it is dark and raining. I will try to check those tomorrow. What would cause the cel to be on with no current codes?
Back to top Go down
albertj
Master
albertj

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 7580
Merit : 154

Riv would not accelerate!  Empty
PostSubject: Re: Riv would not accelerate!    Riv would not accelerate!  EmptyWed Mar 20, 2013 8:17 am

The CEL probably came back on due to a problem.

My guess is you may have a "deferred maintenance" syndrome here.

My guess also is you may be using a code reader that won't read the GM-specific codes. Car-Code by Alex Leper will, so will better handheld scanners (autotap). The generic readers parts stores use will not.

If nothing is mechanically wrong with your transmission, odds are a fluid and filter change will get it going. If you know a place that does power flushing I give that a "maybe" because in my experience and going by posts on this board, most places with the machines do not use them properly. The other thing is that the transmission line pressures need to be checked and adjusted to factory spec. This requires a tech with training/experience or a repair manual... and a Tech II or equivalent scanner.

My further guess is that past service with "additives" has left crud in the valve body and the fix would be to overhaul the transmission. My final guess is there's an electrical problem and you need to check wiring and vacuum lines.
Back to top Go down
albertj
Master
albertj

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 7580
Merit : 154

Riv would not accelerate!  Empty
PostSubject: Re: Riv would not accelerate!    Riv would not accelerate!  EmptyWed Mar 20, 2013 8:26 am

As for your riv cutting off at stop signs - check the wiring at the big junction block at the firewall. Look nor wires in the corners of the bloc to have broken inside the insulation.

I seed you are in PG County. If you are not doing the work yourself, you would be well served to find a mechanic away from the major dealers. Look in small towns toward the panhandle for independent shops with mechanics that actually like keeping older GM cars running. Alternatively ask a gypsy cab driver where people in his association takes cars for service and consider that shop.
Back to top Go down
Sponsored content




Riv would not accelerate!  Empty
PostSubject: Re: Riv would not accelerate!    Riv would not accelerate!  Empty

Back to top Go down
 
Riv would not accelerate!
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   Supercharged 3800 Tech :: Series I Engine & Transmission-
Jump to: