The 8th Gen Riviera Resource
 
HomeDashboardSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

Share
 

 1999 riviera sc3.8 no start, help!!

Go down 
AuthorMessage
luis1991
Newbie


Name : Luis Teran
Joined : 2013-03-26
Post Count : 1
Merit : 0

1999 riviera sc3.8 no start, help!! Empty
PostSubject: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! EmptyTue Mar 26, 2013 8:03 pm

So i have this 1999 Buick Riviera 3.8 supercharged and it was running fine until i did some work to it. I replaced the lower control arms, the valve cover gaskets and also an idler pulley for the supercharger the one that needs the engine mount removed. After all this, now it wont start. It has good spark, good fuel pressure, but no injector pulse. I replaced the crank sensor, cam sensor, the pcm and also part of the wiring harness(the one with the crank and cam sensor plugs and icm plug) thinking i may have messed something up while removing the engine mount. I also hooked up a snap on scan tool to read the rpms while cranking but it reads at 0, which means the pcm isnt receiving a signal from the ckps, so basically this is the problem right? Also, on rare occasions i get injector pulse for like a second and will start for that second. Can anybody help me with this problem, i will highly appreciate any help. Thanks in advance!
Back to top Go down
bigdave
Fanatic


Name : Dave
Age : 55
Location : Cheektowaga , NY (Buffalo)
Joined : 2010-10-17
Post Count : 399
Merit : 22

1999 riviera sc3.8 no start, help!! Empty
PostSubject: Re: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! EmptyTue Mar 26, 2013 8:34 pm

Don't know for sure what your problem might be, but a couple things you could check.Ground wire to motor at right front corner( small wire can easily brake). Security system.
Back to top Go down
Mr.Riviera
Expert
Mr.Riviera

Name : Matthew
Age : 33
Location : Florida
Joined : 2007-01-17
Post Count : 4394
Merit : 101

1999 riviera sc3.8 no start, help!! Empty
PostSubject: Re: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! EmptyTue Mar 26, 2013 8:57 pm

Was the crank sensor and pcm replaced as trial and error to get the car running?

_________________
1996 with 254k miles, L32 4" FWI -> ported N* -> Ported Gen V w/3.0" Pulley, Stage 3 Phenolic I/C, ZZP FMHE, 1.84 RR, Headers and 3" pipe to mufflers, F-body brakes, and lowered on Eibachs. -RIP
AMG C400 White on black -daily
1999 riviera sc3.8 no start, help!! Dsc_0110
Back to top Go down
charlieRobinson
Expert
charlieRobinson

Name : Charlie
Age : 34
Location : Toledo, OH
Joined : 2011-05-17
Post Count : 3921
Merit : 30

1999 riviera sc3.8 no start, help!! Empty
PostSubject: Re: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! EmptyTue Mar 26, 2013 10:17 pm

Sorry your Riv is messed up but I'm glad it brought you to the club. hi
Back to top Go down
stan
Aficionado


Joined : 2007-07-01
Post Count : 2334
Merit : 10

1999 riviera sc3.8 no start, help!! Empty
PostSubject: Re: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! EmptyTue Mar 26, 2013 10:55 pm

Hard to say.....but WELCOME!I believe we'll think of something .
Back to top Go down
albertj
Guru
albertj

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 7407
Merit : 148

1999 riviera sc3.8 no start, help!! Empty
PostSubject: Re: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! EmptyWed Mar 27, 2013 3:22 am

Check for break in cam and crank sensor wiring inside the insulation at the sensor connector. Check for unrelated issue - wiring harness failure at the firewall connector. Backtrack your repairs.
Back to top Go down
LARRY70GS
Aficionado
LARRY70GS

Name : Larry
Age : 63
Location : Oakland Gardens, NY
Joined : 2007-01-23
Post Count : 1685
Merit : 111

1999 riviera sc3.8 no start, help!! Empty
PostSubject: Re: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! EmptyWed Mar 27, 2013 8:50 am

albertj wrote:
Check for break in cam and crank sensor wiring inside the insulation at the sensor connector. Check for unrelated issue - wiring harness failure at the firewall connector. Backtrack your repairs.

Albert,
I found Luis over at www.buickforums.com, and steered him over here. I did suggest he check the harness connection at the firewall, and even linked him to the cam sensor CEL thread. Hopefully, that is the key to his problem as he replaced some pulleys, and disconnected the mount. Maybe that stressed some some of the wiring if the engine position dropped due to the disconnected mount.

http://www.buickforums.com/forums/showthread.php?t=30421

_________________
98 Riviera SC3800  All stock except gutted air box.
1970 Buick GS455 Stage1, TSP built 470BBB, 602HP/589TQ
Best MPH, 116.06 MPH, Best ET, 11.54
https://www.youtube.com/watch?v=UHCda-t_Jls
https://www.youtube.com/watch?v=sfT2tEO4XcU
Back to top Go down
albertj
Guru
albertj

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 7407
Merit : 148

1999 riviera sc3.8 no start, help!! Empty
PostSubject: Re: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! EmptyWed Mar 27, 2013 11:46 am

@Larry: my guess is its most likely a bad splice in the replacement harness, possibly a bad crimp in a connector (those are real difficult to find and fix), maybe a hidden break in the ckp wiring, and if Luis went to the wrong parts store - a ckp that was bad new.


Last edited by albertj on Wed Mar 27, 2013 11:20 pm; edited 1 time in total
Back to top Go down
LARRY70GS
Aficionado
LARRY70GS

Name : Larry
Age : 63
Location : Oakland Gardens, NY
Joined : 2007-01-23
Post Count : 1685
Merit : 111

1999 riviera sc3.8 no start, help!! Empty
PostSubject: Re: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! EmptyWed Mar 27, 2013 7:09 pm

albertj wrote:
@Larry: my guess is its most likely a bad splice in the replacement harness, possibly a bad crimp in a connector (those are real difficult to find and fix), maybe a hidden break in the cop wiring, and if Luis went to the wrong parts store - a ckp that was bad new.

Well, if anyone can help, it's here. Hope he gets it sorted out.

_________________
98 Riviera SC3800  All stock except gutted air box.
1970 Buick GS455 Stage1, TSP built 470BBB, 602HP/589TQ
Best MPH, 116.06 MPH, Best ET, 11.54
https://www.youtube.com/watch?v=UHCda-t_Jls
https://www.youtube.com/watch?v=sfT2tEO4XcU
Back to top Go down
albertj
Guru
albertj

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 7407
Merit : 148

1999 riviera sc3.8 no start, help!! Empty
PostSubject: Re: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! EmptyWed Mar 27, 2013 11:22 pm

I hope so too. I suspect some people can find the advice from this board to be frustrating at first because the answers are questions early on.
Back to top Go down
Sponsored content




1999 riviera sc3.8 no start, help!! Empty
PostSubject: Re: 1999 riviera sc3.8 no start, help!!   1999 riviera sc3.8 no start, help!! Empty

Back to top Go down
 
1999 riviera sc3.8 no start, help!!
Back to top 
Page 1 of 1
 Similar topics
-
» Brisbane Track Class 11/02/11 Start Lists
» Mayan Riviera excursions -- best deals out there
» False start rule causes problems when applied sporadically
» Paris Diamond League - July 8th Provisional START LISTS
» False start rule makes athletes edgy for USA Champs

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   General :: Welcome!-
Jump to: