Riv Performance
Would you like to react to this message? Create an account in a few clicks or log in to continue.

The 8th Gen Riviera Resource
 
HomeDashboardLatest imagesSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

 

 Cam INSTALLED

Go down 
5 posters
AuthorMessage
SpaceBar
Aficionado
SpaceBar


Name : Patrick
Age : 37
Location : Quincy, MA
Joined : 2007-04-08
Post Count : 1199
Merit : 3

Cam INSTALLED Empty
PostSubject: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 9:30 am

So I bring the car down to John F in CT (great guy). He has never worked on a Riv before and didn't know about the engine mount.

We started working on it sunday and it was going pretty good till we got to the mount. Was just a PITA to take off. There were a couple guys from connclubgp there helping out too. We get to the harmonic balancer and tried using the key to get it off and snap the key. Go to pep boys and buy another one. It snaps too. We finally go back and get another one and it takes it off (this process took about an hour and half out of the day). We moved onto getting the cradle bolts off and the first one was a 6!†©️h but it comes off. The second one snapped the socket. We sent one guy to sears to get a replacement and he got there at 6:02, they closed at 6.

So we decided to quit for the day and I had to get a ride home (2 1/2 hour ride) so I could go to work monday and tuesday.

He got the cradle off on tuesday night and put the new cam in.

I got down on wednesday morning and we started to put things back together. Took a while to figure out the engine mount and we get it on and when we got it on and we had the belts routed wrong. Had to take the mount off then get it back on again. Then the power steering was another PITA to get on (the second time I took it off it went on in about 2 minutes). It was getting late by then so we decided to quit for the night and get some food and I just stayed over.

Thursday we start putting the rest back on and it went MUCH better than the previous 2 days. After another couple hours we got everything back together and fired it up. Changed out the oil drove it around the block a bit everything was fine. Changed out the oil again and put in systhetic. Cleaned up the garage and FINALLY DROVE IT HOME.


Car feels much better (have the 3.3" pulley on too) but I haven't got on it too much yet. I want to get the headers in and get it tuned before I go crazy with it. Sounds great too. I'll let you guys know how it really feels when I can get on it more. wink
Back to top Go down
http://community.webshots.com/user/xspacebarx
98riv
Moderator



Location : USA
Joined : 2007-01-14
Post Count : 995
Merit : 30

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 10:19 am

It sounds like you had a tough time getting it installed. I bet you will forget about the install once you go wot.

BTW,
We want videos or a sound clip!

_________________
1998 Supercharged Riviera - Custom CAI, Alpine spx-13ref, Infinity 6x9's, Alpine 4 Channel Amp, Kicker KX3, Silverstars, STB, Hawk Brake Pads, Monroe Air Shocks, KYB GR2
Back to top Go down
SpaceBar
Aficionado
SpaceBar


Name : Patrick
Age : 37
Location : Quincy, MA
Joined : 2007-04-08
Post Count : 1199
Merit : 3

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 10:32 am

98riv wrote:
It sounds like you had a tough time getting it installed. I bet you will forget about the install once you go wot.

BTW,
We want videos or a sound clip!

I was going to get a sound clip of it idling but I don't know where the camera is. I have to get a pic of the nice shiney blower too. Took it home and polished it while it was off. wink

When I find the camera I'll get a clip of the exhaust idle but I can't get a video of WOT until I get it tuned and get the headers in. wink
Back to top Go down
http://community.webshots.com/user/xspacebarx
AA
Administrator
AA


Name : Aaron
Age : 47
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18448
Merit : 252

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 12:46 pm

Wow, congrats! Swap that 3.5" back on and go WOT!!!! Could make a sound clip before and after headers?!!

_________________
'05 GTO 6.0L • 6-spd • 95k miles • 0-60: 4.8s • 16.9 avg MPG • Nelson Ledges Lap: 1:26

'95 Celica GT 2.2L • 5-spd • 165k miles • 0-60: yes

'98 SC Riviera • 281k miles • 298 HP/370 TQ • 0-60: 5.79s • ET: 13.97 @ 99.28 • 4087 lb • 20.1 avg MPG • Nelson Ledges Lap: 1:30
3.4" pulley • AL104 plugs • 180º t-stat • FWI w/K&N • 1.9:1 rockers • OR pushrods • LS6 valve springs • SLP headers • ZZP fuel rails
KYB GR2 struts • MaxAir shocks • Addco sway bars • UMI bushings • GM STB • Enkei 18" EV5s w/ Dunlop DZ101s • F-body calipers
EBC bluestuff/Hawk HP plus • SS lines • Brembo slotted discs • DHP tuned • Aeroforce • Hidden Hitch

^^^ SOLD ^^^ frown

'70 Ninety-Eight Holiday Coupe 455cid • 116k miles
^^^ SOLD ^^^ frown
Back to top Go down
http://www.cardomain.com/ride/657082/4
SpaceBar
Aficionado
SpaceBar


Name : Patrick
Age : 37
Location : Quincy, MA
Joined : 2007-04-08
Post Count : 1199
Merit : 3

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 1:20 pm

AA wrote:
Wow, congrats! Swap that 3.5" back on and go WOT!!!! Could make a sound clip before and after headers?!!

I couldn't get the belt around the 3.5" pulley. The tensioniser is a little stripped and I don't want to touch it again until I get a replacement. I have to break the cam in anyway before I can go WOT on it. wink I can't get the headers put in until after next week anyway so thats probably about when the cam will be broken in and I'll get something up for you guys.
Back to top Go down
http://community.webshots.com/user/xspacebarx
97rivman
Fanatic
97rivman


Name : alex
Age : 38
Location : Crete,IL
Joined : 2007-06-09
Post Count : 484
Merit : 2

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 1:37 pm

well $h!†, if you would have said something earlier, i could have given you the blindfolded guide to getting that on and off. Ive had that mount in and out at least 5 times in a night. between the belts, power steering, and having to grind it down because the belts woulnt work with the power steering. You went to John Francis??? I bet that was fun for him...."what the hell is this thing on the side, and where are the dog bones???" As for the harmonic balancer..I managed to find a puller tool for $30 on ebay wink Well it good to hear another Riv is not stock anymore!!!!
Back to top Go down
SpaceBar
Aficionado
SpaceBar


Name : Patrick
Age : 37
Location : Quincy, MA
Joined : 2007-04-08
Post Count : 1199
Merit : 3

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 1:49 pm

97rivman wrote:
well $h!†, if you would have said something earlier, i could have given you the blindfolded guide to getting that on and off. Ive had that mount in and out at least 5 times in a night. between the belts, power steering, and having to grind it down because the belts woulnt work with the power steering. You went to John Francis??? I bet that was fun for him...."what the hell is this thing on the side, and where are the dog bones???" As for the harmonic balancer..I managed to find a puller tool for $30 on ebay wink Well it good to hear another Riv is not stock anymore!!!!

Hah John's exact words when I opened the hood were "What the fµ©️k is that."

I'm a god damn pro at the engine mount now. The last time I think it took like 10 minutes. I'm not stock anymore but I'm not going anywhere as far as you did. wink

The hormonic balancer was screwed up on in inside where the key went into thats why they broke. Looks like someone had it off before to change the crank position sensor (looks pretty new). They must have screwed it up.
Back to top Go down
http://community.webshots.com/user/xspacebarx
AA
Administrator
AA


Name : Aaron
Age : 47
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18448
Merit : 252

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 2:24 pm

Lol: "..before the cam"

Your next PB will probably be a full second better.

_________________
'05 GTO 6.0L • 6-spd • 95k miles • 0-60: 4.8s • 16.9 avg MPG • Nelson Ledges Lap: 1:26

'95 Celica GT 2.2L • 5-spd • 165k miles • 0-60: yes

'98 SC Riviera • 281k miles • 298 HP/370 TQ • 0-60: 5.79s • ET: 13.97 @ 99.28 • 4087 lb • 20.1 avg MPG • Nelson Ledges Lap: 1:30
3.4" pulley • AL104 plugs • 180º t-stat • FWI w/K&N • 1.9:1 rockers • OR pushrods • LS6 valve springs • SLP headers • ZZP fuel rails
KYB GR2 struts • MaxAir shocks • Addco sway bars • UMI bushings • GM STB • Enkei 18" EV5s w/ Dunlop DZ101s • F-body calipers
EBC bluestuff/Hawk HP plus • SS lines • Brembo slotted discs • DHP tuned • Aeroforce • Hidden Hitch

^^^ SOLD ^^^ frown

'70 Ninety-Eight Holiday Coupe 455cid • 116k miles
^^^ SOLD ^^^ frown
Back to top Go down
http://www.cardomain.com/ride/657082/4
97rivman
Fanatic
97rivman


Name : alex
Age : 38
Location : Crete,IL
Joined : 2007-06-09
Post Count : 484
Merit : 2

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 4:40 pm

AA wrote:
Lol: "..before the cam"

Your next PB will probably be a full second better.

thats of course....assuming he can get traction dunce thumbsup
Back to top Go down
turtleman
Expert
turtleman


Name : Codith
Age : 36
Location : Villa Park, IL
Joined : 2007-02-08
Post Count : 3671
Merit : 140

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 7:28 pm

thats awesome! I must have missed this but which cam did you get?
Back to top Go down
SpaceBar
Aficionado
SpaceBar


Name : Patrick
Age : 37
Location : Quincy, MA
Joined : 2007-04-08
Post Count : 1199
Merit : 3

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 11:36 pm

97rivman wrote:
AA wrote:
Lol: "..before the cam"

Your next PB will probably be a full second better.

thats of course....assuming he can get traction dunce thumbsup

I'm hoping to do better than just a second. wink

Assuming I get traction. I deserved that. wink

I got the S1X from Intense.
Back to top Go down
http://community.webshots.com/user/xspacebarx
AA
Administrator
AA


Name : Aaron
Age : 47
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18448
Merit : 252

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptyFri Jul 06, 2007 11:45 pm

I'm cam-illiterate, but I hope the SEX cam does what you're expecting. wink

_________________
'05 GTO 6.0L • 6-spd • 95k miles • 0-60: 4.8s • 16.9 avg MPG • Nelson Ledges Lap: 1:26

'95 Celica GT 2.2L • 5-spd • 165k miles • 0-60: yes

'98 SC Riviera • 281k miles • 298 HP/370 TQ • 0-60: 5.79s • ET: 13.97 @ 99.28 • 4087 lb • 20.1 avg MPG • Nelson Ledges Lap: 1:30
3.4" pulley • AL104 plugs • 180º t-stat • FWI w/K&N • 1.9:1 rockers • OR pushrods • LS6 valve springs • SLP headers • ZZP fuel rails
KYB GR2 struts • MaxAir shocks • Addco sway bars • UMI bushings • GM STB • Enkei 18" EV5s w/ Dunlop DZ101s • F-body calipers
EBC bluestuff/Hawk HP plus • SS lines • Brembo slotted discs • DHP tuned • Aeroforce • Hidden Hitch

^^^ SOLD ^^^ frown

'70 Ninety-Eight Holiday Coupe 455cid • 116k miles
^^^ SOLD ^^^ frown
Back to top Go down
http://www.cardomain.com/ride/657082/4
97rivman
Fanatic
97rivman


Name : alex
Age : 38
Location : Crete,IL
Joined : 2007-06-09
Post Count : 484
Merit : 2

Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED EmptySat Jul 07, 2007 3:50 am

Ive got a stage 3 Cam scat
Back to top Go down
Sponsored content





Cam INSTALLED Empty
PostSubject: Re: Cam INSTALLED   Cam INSTALLED Empty

Back to top Go down
 
Cam INSTALLED
Back to top 
Page 1 of 1
 Similar topics
-
» FWI installed
» NEW CARB FOR MY 307 I INSTALLED
» Installed a new motor, but it's not quite right...
» Write-Up: Installing SLP Exhaust Headers
» Write-Up: Installing KYB GR-2 Struts

Permissions in this forum:You cannot reply to topics in this forum
Riv Performance ::   Supercharged 3800 Tech :: Series II Engine & Transmission-
Jump to: