Riv Performance
Would you like to react to this message? Create an account in a few clicks or log in to continue.

The 8th Gen Riviera Resource
 
HomeDashboardLatest imagesSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

 

 Temp guage reading negative

Go down 
3 posters
AuthorMessage
SpaceBar
Aficionado
SpaceBar


Name : Patrick
Age : 37
Location : Quincy, MA
Joined : 2007-04-08
Post Count : 1199
Merit : 3

Temp guage reading negative Empty
PostSubject: Temp guage reading negative   Temp guage reading negative EmptySun Jul 22, 2007 8:56 pm

The temperature is right its just reading it -75* instead of 75*.

The battery died while I was putting in the aeroforce gauge and when I jumped the car thats how the temp read.

Anyone know how to fix this?
Back to top Go down
http://community.webshots.com/user/xspacebarx
AA
Administrator
AA


Name : Aaron
Age : 47
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18448
Merit : 252

Temp guage reading negative Empty
PostSubject: Re: Temp guage reading negative   Temp guage reading negative EmptySun Jul 22, 2007 9:36 pm

Check polarity? Maybe wires are connected backward.

_________________
'05 GTO 6.0L • 6-spd • 95k miles • 0-60: 4.8s • 16.9 avg MPG • Nelson Ledges Lap: 1:26

'95 Celica GT 2.2L • 5-spd • 165k miles • 0-60: yes

'98 SC Riviera • 281k miles • 298 HP/370 TQ • 0-60: 5.79s • ET: 13.97 @ 99.28 • 4087 lb • 20.1 avg MPG • Nelson Ledges Lap: 1:30
3.4" pulley • AL104 plugs • 180º t-stat • FWI w/K&N • 1.9:1 rockers • OR pushrods • LS6 valve springs • SLP headers • ZZP fuel rails
KYB GR2 struts • MaxAir shocks • Addco sway bars • UMI bushings • GM STB • Enkei 18" EV5s w/ Dunlop DZ101s • F-body calipers
EBC bluestuff/Hawk HP plus • SS lines • Brembo slotted discs • DHP tuned • Aeroforce • Hidden Hitch

^^^ SOLD ^^^ frown

'70 Ninety-Eight Holiday Coupe 455cid • 116k miles
^^^ SOLD ^^^ frown
Back to top Go down
http://www.cardomain.com/ride/657082/4
SpaceBar
Aficionado
SpaceBar


Name : Patrick
Age : 37
Location : Quincy, MA
Joined : 2007-04-08
Post Count : 1199
Merit : 3

Temp guage reading negative Empty
PostSubject: Re: Temp guage reading negative   Temp guage reading negative EmptySun Jul 22, 2007 9:45 pm

I didn't touch any wires with that? All I did was connect to aeroforce gauge to a set of wires. It connects to the lights wires.
Back to top Go down
http://community.webshots.com/user/xspacebarx
racinfan
Addict
racinfan


Name : Joe
Location : Cleveland, OH
Joined : 2007-02-05
Post Count : 567
Merit : 5

Temp guage reading negative Empty
PostSubject: Re: Temp guage reading negative   Temp guage reading negative EmptySun Jul 22, 2007 11:53 pm

You left the battery hooked up while doing electrical work?

Unhook the battery for a bit and then see if that resets it.
Back to top Go down
SpaceBar
Aficionado
SpaceBar


Name : Patrick
Age : 37
Location : Quincy, MA
Joined : 2007-04-08
Post Count : 1199
Merit : 3

Temp guage reading negative Empty
PostSubject: Re: Temp guage reading negative   Temp guage reading negative EmptyWed Jul 25, 2007 10:05 pm

Tried unhooking the battery, got nothing. Still says the same thing.
Back to top Go down
http://community.webshots.com/user/xspacebarx
Sponsored content





Temp guage reading negative Empty
PostSubject: Re: Temp guage reading negative   Temp guage reading negative Empty

Back to top Go down
 
Temp guage reading negative
Back to top 
Page 1 of 1
 Similar topics
-
» Temp guage issue......1995 Riv 3800 series 1 SC
» Write-Up: A-Pillar Re-Upholstery & Guage Pods
» Gas Guage.
» Write-Up: Installing Boost Gauge
» guage cluster possibilities

Permissions in this forum:You cannot reply to topics in this forum
Riv Performance ::   General Tech :: Interior-
Jump to: