Riviera Performance
Would you like to react to this message? Create an account in a few clicks or log in to continue.

The 8th Gen Riviera Resource
 
HomeDashboardSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

 

 FAQ: Mass Air Flow (MAF) Sensor Issues?

Go down 
Go to page : 1, 2, 3 ... 11, 12, 13  Next
AuthorMessage
SpaceBar
Aficionado
SpaceBar

Name : Patrick
Age : 33
Location : Quincy, MA
Joined : 2007-04-08
Post Count : 1199
Merit : 3

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: MAF Sensor cleaning   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptySun Jul 15, 2007 4:43 pm

After i got the cam installed I put on the 3.3" pulley because the belt wouldn't fit around the 3.5". I don't have the headers on yet either.

Just got an aeroforce scanner and I was getting around 7* of knock at about 80% throttle. I was getting between 1-3* in low throttle.

I used some electronic cleaner today on the MAF sensor. Went for a few runs after I did it and I'm not getting any knock under light throttle anymore. I'm only getting between 2-3* at around the 80% throttle now.

Its the same temperature as it was earlier. I did the other scans about an hour before it.

Does that make any sense to you guys?

It also did a surging thing before when I was stopped or just started it. It didn't do it all the time but it usually did it at least once each drive. I didn't get that either.
Back to top Go down
http://community.webshots.com/user/xspacebarx
AA
Administrator
AA

Name : Aaron
Age : 43
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18403
Merit : 245

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptySun Jul 15, 2007 5:52 pm

Possible, imo. Did you fill up with gas before the 2nd scan? Just to be sure, do another scan in a day or two. If the results are consistent, I'd say it was the MAF. Have you tuned for the cam yet?

_________________
'98 SC Riviera • 281k miles • 298 HP/370 TQ • 0-60: 5.79s • ET: 13.97 @ 99.28 • 4087 lb • 20.1 avg MPG • Nelson Ledges Lap: 1:30
3.4" pulley • AL104 plugs • 180º t-stat • FWI w/K&N • 1.9:1 rockers • OR pushrods • LS6 valve springs • SLP headers • ZZP fuel rails
KYB GR2 struts • MaxAir shocks • Addco sway bars • UMI bushings • GM STB • Enkei 18" EV5s w/ Dunlop DZ101s • F-body calipers
EBC bluestuff/Hawk HP plus • SS lines • Brembo slotted discs • DHP tuned • Aeroforce • Hidden Hitch

^^^ SOLD ^^^ frown

'05 GTO • 85k miles • 0-60: 4.8s • 16.9 avg MPG • Nelson Ledges Lap: 1:26
Because fun


'70 Olds Ninety-Eight Holiday Coupe • 116k miles • 455 Rocket V8
Because cool


'95 Celica • 152k miles • 0-60: yes
Because free
Back to top Go down
http://www.cardomain.com/ride/657082/4 Online
SpaceBar
Aficionado
SpaceBar

Name : Patrick
Age : 33
Location : Quincy, MA
Joined : 2007-04-08
Post Count : 1199
Merit : 3

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptySun Jul 15, 2007 6:05 pm

AA wrote:
Possible, imo. Did you fill up with gas before the 2nd scan? Just to be sure, do another scan in a day or two. If the results are consistent, I'd say it was the MAF. Have you tuned for the cam yet?

I have the same gas as the scans before it. I filled up a couple days ago.

I was cleaning the MAF because I read it was supposed to help with the surging.

I haven't tuned for the cam yet. I'm getting the headers put in next week and then Derek is going to tune the car when he gets back from vacation.


All the scans I've done until after I cleaned the MAF had bad KR issues. I'll do some more tonight and tomorrow and I'll see how they are.
Back to top Go down
http://community.webshots.com/user/xspacebarx
T Riley
Guru
T Riley

Name : Travis
Age : 30
Location : Your wife's box
Joined : 2007-02-08
Post Count : 5126
Merit : 9

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: P0102 Code, Mass Air Flow sensor/or connector is whacked   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptySun Jun 01, 2008 12:27 am

on my LS1M i normally see at least 260ish Horepower, now i see 222 frown ......... basically my MAF doesn't exist....... my car idle's sorta funny....... my teacher said that if i unplug my MAF that my PCM will use the TPS........... i ordered a new connector for my MAF since that is my issue........ ALSO i will be buyin MAF cleaner........


so BASICALLY..... is it normal to lose power with my MAF being lame?
Back to top Go down
http://www.rivperformance.com
Mr.Riviera
Expert
Mr.Riviera

Name : Matthew
Age : 33
Location : Florida
Joined : 2007-01-17
Post Count : 4394
Merit : 101

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptySun Jun 01, 2008 8:42 am

yes, with the MAF gone your pcm will go into limp mode. try a good cleaning before you replace it.

_________________
1996 with 254k miles, L32 4" FWI -> ported N* -> Ported Gen V w/3.0" Pulley, Stage 3 Phenolic I/C, ZZP FMHE, 1.84 RR, Headers and 3" pipe to mufflers, F-body brakes, and lowered on Eibachs. -RIP
AMG C400 White on black -daily
Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Dsc_0110
Back to top Go down
ibmoses
Aficionado
ibmoses

Name : Bert
Location : North Alabama
Joined : 2008-02-03
Post Count : 1701
Merit : 32

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptySun Jun 01, 2008 9:16 am

98riviera98 wrote:
on my LS1M i normally see at least 260ish Horepower, now i see 222 frown ......... basically my MAF doesn't exist....... my car idle's sorta funny....... my teacher said that if i unplug my MAF that my PCM will use the TPS........... i ordered a new connector for my MAF since that is my issue........ ALSO i will be buyin MAF cleaner........


so BASICALLY..... is it normal to lose power with my MAF being lame?

Do the wires have to be cut/spliced to replace the MAF connector?

Bert tavis
Back to top Go down
T Riley
Guru
T Riley

Name : Travis
Age : 30
Location : Your wife's box
Joined : 2007-02-08
Post Count : 5126
Merit : 9

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptySun Jun 01, 2008 1:26 pm

ibmoses wrote:


Do the wires have to be cut/spliced to replace the MAF connector?

Bert tavis


YES THEY DO!!!!!!
Back to top Go down
http://www.rivperformance.com
98riv
Moderator


Location : USA
Joined : 2007-01-14
Post Count : 984
Merit : 30

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptySun Jun 01, 2008 5:01 pm

Are you sure that it isn't the maf that is bad? I would try to clean it first and then see if it needs replacing. Also, the horsepower numbers aren't that accurate on the LS1m. It is a cool little feature though.

_________________
1998 Supercharged Riviera - Custom CAI, Alpine spx-13ref, Infinity 6x9's, Alpine 4 Channel Amp, Kicker KX3, Silverstars, STB, Hawk Brake Pads, Monroe Air Shocks, KYB GR2
Back to top Go down
AA
Administrator
AA

Name : Aaron
Age : 43
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18403
Merit : 245

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptySun Jun 01, 2008 10:02 pm

Considering that I've seen gains and losses of 10 WHP on the dyno just form tweaking the MAFF table, I can believe a substantial loss could occur if your MAF sensor wasn't communicating at all with the PCM. Even more so with mods than in a stock car.

_________________
'98 SC Riviera • 281k miles • 298 HP/370 TQ • 0-60: 5.79s • ET: 13.97 @ 99.28 • 4087 lb • 20.1 avg MPG • Nelson Ledges Lap: 1:30
3.4" pulley • AL104 plugs • 180º t-stat • FWI w/K&N • 1.9:1 rockers • OR pushrods • LS6 valve springs • SLP headers • ZZP fuel rails
KYB GR2 struts • MaxAir shocks • Addco sway bars • UMI bushings • GM STB • Enkei 18" EV5s w/ Dunlop DZ101s • F-body calipers
EBC bluestuff/Hawk HP plus • SS lines • Brembo slotted discs • DHP tuned • Aeroforce • Hidden Hitch

^^^ SOLD ^^^ frown

'05 GTO • 85k miles • 0-60: 4.8s • 16.9 avg MPG • Nelson Ledges Lap: 1:26
Because fun


'70 Olds Ninety-Eight Holiday Coupe • 116k miles • 455 Rocket V8
Because cool


'95 Celica • 152k miles • 0-60: yes
Because free
Back to top Go down
http://www.cardomain.com/ride/657082/4 Online
deekster_caddy
Master


Name : Derek
Age : 48
Location : Reading, MA
Joined : 2007-01-31
Post Count : 7717
Merit : 109

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptySun Jun 01, 2008 10:32 pm

You should NOT go WOT without the MAF unless you have extensively tuned your VE table.

If you unplug the MAF does it run any differently than when it's plugged in?
Back to top Go down
T Riley
Guru
T Riley

Name : Travis
Age : 30
Location : Your wife's box
Joined : 2007-02-08
Post Count : 5126
Merit : 9

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyMon Jun 02, 2008 12:04 am

deekster_caddy wrote:
You should NOT go WOT without the MAF unless you have extensively tuned your VE table.

If you unplug the MAF does it run any differently than when it's plugged in?

Bingo YOU WIN!

i have my MAF unplugged so my PCM doesnt commit suicide.......... it runs rougher with the MAF plugged in shocked unplugged it still scares me to drive...


nope my VE table isnt tuned.
Back to top Go down
http://www.rivperformance.com
BillBoost37
Junkie


Location : Enfield CT
Joined : 2007-11-28
Post Count : 769
Merit : 25

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyMon Jun 02, 2008 9:14 am

Righto.. when you are missing the maf sensor your car doesn't hit GM's version of limp mode. That's actually something different. The PCM reverts to the VE table to base the airflow off the expectations from other sensors and values.

A tuned VE table is a great thing. Really changes the way the motor runs with and without the sensor being unplugged. .
Back to top Go down
T Riley
Guru
T Riley

Name : Travis
Age : 30
Location : Your wife's box
Joined : 2007-02-08
Post Count : 5126
Merit : 9

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyMon Jun 02, 2008 9:15 am

BillBoost37 wrote:
Righto.. when you are missing the maf sensor your car doesn't hit GM's version of limp mode. That's actually something different. The PCM reverts to the VE table to base the airflow off the expectations from other sensors and values.

A tuned VE table is a great thing. Really changes the way the motor runs with and without the sensor being unplugged. .

i will be talking with my tuner bounce
Back to top Go down
http://www.rivperformance.com
54_nailhead
Enthusiast
54_nailhead

Name : Luke
Age : 44
Location : Waconia, MN
Joined : 2007-06-15
Post Count : 126
Merit : 3

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyMon Jun 09, 2008 7:31 pm

SES light was coming on in my car and mechanic said the code was for the mass airflow sensor. I'm picking up a replaecement tomorrow but will it hurt the car at all to drive it if it goes out completely between now and when the new one gets put on?
Back to top Go down
96RivSCMI
Enthusiast
96RivSCMI

Name : Kenon
Age : 35
Location : Wright City, MO
Joined : 2007-01-23
Post Count : 123
Merit : 2

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyMon Jun 09, 2008 7:46 pm

It will still run, but you should not go WOT. Your PCM reverts to other sensors to run your engine.

Have you tried cleaning your MAF?
Back to top Go down
54_nailhead
Enthusiast
54_nailhead

Name : Luke
Age : 44
Location : Waconia, MN
Joined : 2007-06-15
Post Count : 126
Merit : 3

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyMon Jun 09, 2008 7:52 pm

Haven't tried cleaning the MAF. No WOT either, just driving back and forth to work...
Back to top Go down
98RIV7777
Fanatic
98RIV7777

Name : Anthony
Age : 33
Location : Niagara Falls, NY
Joined : 2008-06-01
Post Count : 274
Merit : 1

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyMon Jun 09, 2008 11:51 pm

Ya, definately try cleaning it first, because they are not cheap
Back to top Go down
T Riley
Guru
T Riley

Name : Travis
Age : 30
Location : Your wife's box
Joined : 2007-02-08
Post Count : 5126
Merit : 9

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyTue Jun 10, 2008 1:24 am

54_nailhead wrote:
SES light was coming on in my car and mechanic said the code was for the mass airflow sensor. I'm picking up a replaecement tomorrow but will it hurt the car at all to drive it if it goes out completely between now and when the new one gets put on?

it must be a minnesota thing......... i replaced my wire going from my MAF connector to the PCM....... it worked smile
Back to top Go down
http://www.rivperformance.com
dreww
Junkie
dreww

Location : Dallas
Joined : 2007-04-10
Post Count : 851
Merit : 9

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyTue Jun 10, 2008 1:36 pm

54_nailhead wrote:
Haven't tried cleaning the MAF. No WOT either, just driving back and forth to work...

going WOT is cleaning the MAF. lmao
Back to top Go down
54_nailhead
Enthusiast
54_nailhead

Name : Luke
Age : 44
Location : Waconia, MN
Joined : 2007-06-15
Post Count : 126
Merit : 3

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyTue Jun 10, 2008 6:17 pm

I know new ones aren't cheap, picked up a used one and it's fine now.
Back to top Go down
1998 Riv
Expert
1998 Riv

Name : Dave
Age : 59
Location : In The AZ Oven
Joined : 2007-01-17
Post Count : 4502
Merit : 44

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyTue Jun 10, 2008 10:46 pm

Glad to hear the repl sensor solved the problem. If you saved the old sensor, you should try cleaning it with CRC sensor/electronics spray cleaner, and swapping it back to test. Could have been just dirty, worth checking it out. smile
Back to top Go down
54_nailhead
Enthusiast
54_nailhead

Name : Luke
Age : 44
Location : Waconia, MN
Joined : 2007-06-15
Post Count : 126
Merit : 3

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyWed Jun 11, 2008 8:25 pm

I thouht about that but the mechanic kept it. I'll probably get some of that and keep on hand just in case since the one that's in there now is used.
Back to top Go down
98RIV7777
Fanatic
98RIV7777

Name : Anthony
Age : 33
Location : Niagara Falls, NY
Joined : 2008-06-01
Post Count : 274
Merit : 1

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyThu Jun 12, 2008 2:09 am

Hopefully he didnt just clean yours and lie about changing it. There are alot of mechanics that do those kinds of things to people sadly
Back to top Go down
54_nailhead
Enthusiast
54_nailhead

Name : Luke
Age : 44
Location : Waconia, MN
Joined : 2007-06-15
Post Count : 126
Merit : 3

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyThu Jun 12, 2008 8:38 pm

I was right there when he changed it. Actually I picked up the used one for him and took it to his shop, the place that had it was on my way home from work.
Back to top Go down
98RIV7777
Fanatic
98RIV7777

Name : Anthony
Age : 33
Location : Niagara Falls, NY
Joined : 2008-06-01
Post Count : 274
Merit : 1

Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? EmptyThu Jun 12, 2008 9:04 pm

oh thats good, but why didnt you just try cleaning it first, did you get a really good deal on it?
Back to top Go down
Sponsored content




Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty
PostSubject: Re: FAQ: Mass Air Flow (MAF) Sensor Issues?   Maff sensor issue - FAQ: Mass Air Flow (MAF) Sensor Issues? Empty

Back to top Go down
 
FAQ: Mass Air Flow (MAF) Sensor Issues?
Back to top 
Page 1 of 13Go to page : 1, 2, 3 ... 11, 12, 13  Next
 Similar topics
-
» Outdoor Showers and other Gray Water issues
» Tomato issues
» Is anyone else having issues with flies and gnats??
» Squash issues
» Spacing Issues..

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   General Tech :: Care & Maintenance-
Jump to: