Riviera Performance
Would you like to react to this message? Create an account in a few clicks or log in to continue.

The 8th Gen Riviera Resource
 
HomeDashboardSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

 

 No MIL light when key is turned on

Go down 
AuthorMessage
woggy
Enthusiast
woggy

Name : Paul
Age : 58
Location : Altoona, Florida (Somewhere in the ocala national forest)
Joined : 2009-04-28
Post Count : 201
Merit : 7

No MIL light when key is turned on Empty
PostSubject: No MIL light when key is turned on   No MIL light when key is turned on EmptyThu May 21, 2009 12:01 pm

Anyone ever see this? I have no service engine soon light when the key is turned on. Also no injector pulse. No DTC's.. Bulb and circuit is good (put power to mil circuit at ecm and bulb lights) and good spark. vehicle will run off of starting fluid.

Any help would be appreciated.

95 Riviera 3.8 s.c.
here is a list of new working parts.
3 ecm's (good power and grounds also)
ign module
crank sensor
cam sensor
knock sensor
tps
fuel pump (45 psi key on)
vats bypass module (bypasses key resistor and enables fuel injector pulse. Still no injector pulse. so I took it off)
did a vats relearn or reset

If someone can help at all please do.
Ive been working on this for a month now.
Back to top Go down
deekster_caddy
Master


Name : Derek
Age : 48
Location : Reading, MA
Joined : 2007-01-31
Post Count : 7717
Merit : 109

No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on EmptyThu May 21, 2009 12:22 pm

Sounds like you are stuck in VATS issue to me, but I am not very good with them...
Back to top Go down
woggy
Enthusiast
woggy

Name : Paul
Age : 58
Location : Altoona, Florida (Somewhere in the ocala national forest)
Joined : 2009-04-28
Post Count : 201
Merit : 7

No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on EmptyThu May 21, 2009 2:47 pm

would a vats issus cause no mil light ?
Back to top Go down
manofmany
Addict


Name : manofmany
Age : 36
Joined : 2008-07-26
Post Count : 611
Merit : 5

No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on EmptyThu May 21, 2009 6:43 pm

Really sounds like an ignition switch to me. Maybe it's time to have it diagnosed so you don't keep throwing parts at it... I know thats tough
Back to top Go down
Eldo
Expert
Eldo

Name : Mark
Age : 55
Location : West Salem, Oregon... FINALLY
Joined : 2009-04-09
Post Count : 3068
Merit : 103

No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on EmptyThu May 21, 2009 7:45 pm

Manofmany may well be right about the ignition switch. There are 4 or 5 separate IGN contacts in that switch, and one bad one could be the culprit... Also, with over 55 fuses in these cars, it could be a blown fuse.

Is there anything else that's not working, like the door/key chime or the remote access functions?

I don't have a '95 manual, but in '98 the first fuse I'd check would be number 9 in the dashboard fuse panel.

The one false note in your description is that you tested the SES bulb by putting power to the connector at the PCM... From what I can tell, you should have ignition power to one side of the bulb, and like most everything else in the car the PCM supplies the ground to turn it on.
Back to top Go down
woggy
Enthusiast
woggy

Name : Paul
Age : 58
Location : Altoona, Florida (Somewhere in the ocala national forest)
Joined : 2009-04-28
Post Count : 201
Merit : 7

No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on EmptyFri May 22, 2009 10:44 am

Thanks for everyones input. Its greatly appreciated.
I had my neighbor who is a mechanic also, come over to help me out.
he brought about 50 pages of diagnosis charts from alldata.
after 3 hours of troubleshooting we found bad connections on the ecm plugs. not one but numerous wires. so now the question is to splice a whole new connector in or replace all 38 pins.
anyways Ill let you all know how this works out.
Back to top Go down
deekster_caddy
Master


Name : Derek
Age : 48
Location : Reading, MA
Joined : 2007-01-31
Post Count : 7717
Merit : 109

No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on EmptyFri May 22, 2009 11:19 am

Wow. It might be easier to find a full harness from a junkyard... might be faster than checking every single wire.
Back to top Go down
woggy
Enthusiast
woggy

Name : Paul
Age : 58
Location : Altoona, Florida (Somewhere in the ocala national forest)
Joined : 2009-04-28
Post Count : 201
Merit : 7

No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on EmptyFri Jun 05, 2009 12:17 pm

Just an Update:
I ended up tracing around 120 wires from the ecm and found 1 stinking wire that was supposed to have 12 volts and was reading 0.
Ran a new wire and BAM she fired right up.
Back to top Go down
albertj
Master
albertj

Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 7833
Merit : 164

No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on EmptyFri Jun 05, 2009 2:29 pm

any physical evidence suggesting why the one wire went bad?

Albertj
Back to top Go down
deekster_caddy
Master


Name : Derek
Age : 48
Location : Reading, MA
Joined : 2007-01-31
Post Count : 7717
Merit : 109

No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on EmptyFri Jun 05, 2009 5:23 pm

and which wire was it???
Back to top Go down
woggy
Enthusiast
woggy

Name : Paul
Age : 58
Location : Altoona, Florida (Somewhere in the ocala national forest)
Joined : 2009-04-28
Post Count : 201
Merit : 7

No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on EmptyMon Jun 08, 2009 11:52 am

no physical evidence of any wire going or gone bad. It started one minute and the next NOTTA!
The suspect wire was WD5 white ecm connector wire #5 (pink) this wire controls maf sensor and ign filter whatever that is... It is supposed to have 12 volts or Battery +

On a new note a new code 1640 has popped up this is qdm#1 failure
car has no power at all. and no passing gear when I punch it. hmmm what next!?
Back to top Go down
Sponsored content




No MIL light when key is turned on Empty
PostSubject: Re: No MIL light when key is turned on   No MIL light when key is turned on Empty

Back to top Go down
 
No MIL light when key is turned on
Back to top 
Page 1 of 1
 Similar topics
-
» Hot Water Heater
» help! christmas light in hoop house
» Grow Light Bulbs
» plants turning light green/yellow
» Gardening by the light of the moon

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   Supercharged 3800 Tech :: Series I Engine & Transmission-
Jump to: