Riv Performance
Would you like to react to this message? Create an account in a few clicks or log in to continue.

The 8th Gen Riviera Resource
 
HomeDashboardLatest imagesSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

 

 In need of some advice for 95 rivi

Go down 
+3
jax95riv
Brad95Riv
heyzelchi
7 posters
AuthorMessage
heyzelchi
Amateur



Joined : 2007-10-03
Post Count : 29
Merit : 0

In need of some advice for 95 rivi Empty
PostSubject: In need of some advice for 95 rivi   In need of some advice for 95 rivi EmptyMon Dec 10, 2007 1:24 pm

Ok I have an 95 riv sc I'm not getting any heat or a/c does nor does the front windshield defroster work I'm thinkin that it might be something wrong with the vents,or blower control module, the climate controls works I hear when the heat and a/c active but nothing comes out the vents?
Back to top Go down
Brad95Riv
Member
Brad95Riv


Name : Brad
Age : 43
Location : Wisconsin
Joined : 2007-01-18
Post Count : 97
Merit : 0

In need of some advice for 95 rivi Empty
PostSubject: Re: In need of some advice for 95 rivi   In need of some advice for 95 rivi EmptyMon Dec 10, 2007 1:56 pm

Does the blower motor (fan) change speeds when you change the fan speed on the climate control unit? If not, it's probably either a bad blower motor or a bad blower motor resistor. Both of them are located behind the passenger side kick panel.
Back to top Go down
jax95riv
Aficionado
jax95riv


Name : Jack
Age : 61
Location : Oklahoma City
Joined : 2007-01-14
Post Count : 1062
Merit : 6

In need of some advice for 95 rivi Empty
PostSubject: Re: In need of some advice for 95 rivi   In need of some advice for 95 rivi EmptyMon Dec 10, 2007 7:36 pm

It could be the climate control unit too...
Back to top Go down
http://www.cardomain.com/ride/468780
heyzelchi
Amateur



Joined : 2007-10-03
Post Count : 29
Merit : 0

In need of some advice for 95 rivi Empty
PostSubject: Re: In need of some advice for 95 rivi   In need of some advice for 95 rivi EmptyMon Dec 10, 2007 10:07 pm

Brad95Riv wrote:
Does the blower motor (fan) change speeds when you change the fan speed on the climate control unit? If not, it's probably either a bad blower motor or a bad blower motor resistor. Both of them are located behind the passenger side kick panel.


the blower fans does not come on and the climate control works properly the problem is that it no heat or a/c coming out of the vents at all
Back to top Go down
imaspaceguy90
Special



Joined : 2007-12-06
Post Count : 5
Merit : 0

In need of some advice for 95 rivi Empty
PostSubject: Re: In need of some advice for 95 rivi   In need of some advice for 95 rivi EmptyMon Dec 10, 2007 10:11 pm

Its your blower motor then, the reason you hear it kicking on is because it is working however the blower motor is not pushing the air threw the vents.
Back to top Go down
AA
Administrator
AA


Name : Aaron
Age : 46
Location : C-bus, Ohio
Joined : 2007-01-13
Post Count : 18438
Merit : 248

In need of some advice for 95 rivi Empty
PostSubject: Re: In need of some advice for 95 rivi   In need of some advice for 95 rivi EmptyTue Dec 11, 2007 12:22 am

A bad blower control module can cause no air to flow, even if the blower is working. In my case, everything worked, but the blower wasn't turning on. I replaced the module with a used one from Ed Morad ($30 I think) and problem was fixed.

_________________
'05 GTO 6.0L • 6-spd • 95k miles • 0-60: 4.8s • 16.9 avg MPG • Nelson Ledges Lap: 1:26

'95 Celica GT 2.2L • 5-spd • 165k miles • 0-60: yes

'98 SC Riviera • 281k miles • 298 HP/370 TQ • 0-60: 5.79s • ET: 13.97 @ 99.28 • 4087 lb • 20.1 avg MPG • Nelson Ledges Lap: 1:30
3.4" pulley • AL104 plugs • 180º t-stat • FWI w/K&N • 1.9:1 rockers • OR pushrods • LS6 valve springs • SLP headers • ZZP fuel rails
KYB GR2 struts • MaxAir shocks • Addco sway bars • UMI bushings • GM STB • Enkei 18" EV5s w/ Dunlop DZ101s • F-body calipers
EBC bluestuff/Hawk HP plus • SS lines • Brembo slotted discs • DHP tuned • Aeroforce • Hidden Hitch

^^^ SOLD ^^^ frown

'70 Ninety-Eight Holiday Coupe 455cid • 116k miles
^^^ SOLD ^^^ frown
Back to top Go down
http://www.cardomain.com/ride/657082/4
turtleman
Expert
turtleman


Name : Codith
Age : 35
Location : Villa Park, IL
Joined : 2007-02-08
Post Count : 3671
Merit : 140

In need of some advice for 95 rivi Empty
PostSubject: Re: In need of some advice for 95 rivi   In need of some advice for 95 rivi EmptyTue Dec 11, 2007 12:40 am

I hate to just jump in and take the thread but it seems better than making another one about the same thing.

I've only recently noticed on my 97 that My air blows and its warm and everything but when I switch it to blow in the upper vents instead of the floor, nothing comes out of the upper vents... I don't think on either side of the car. blower is definitely running

So the bottom works and the defrosters seems to work up on top but not a trace of air out of the upper (middle) vents
Back to top Go down
ewolfe0050
Aficionado
ewolfe0050


Name : Eric
Location : Indianapolis, IN
Joined : 2007-07-31
Post Count : 1159
Merit : 27

In need of some advice for 95 rivi Empty
PostSubject: Re: In need of some advice for 95 rivi   In need of some advice for 95 rivi EmptyTue Dec 11, 2007 1:05 am

I thought I read a thread in here that addressed sticking flaps in the vent system. If I find it, I'll send it along.
Back to top Go down
Brad95Riv
Member
Brad95Riv


Name : Brad
Age : 43
Location : Wisconsin
Joined : 2007-01-18
Post Count : 97
Merit : 0

In need of some advice for 95 rivi Empty
PostSubject: Re: In need of some advice for 95 rivi   In need of some advice for 95 rivi EmptyTue Dec 11, 2007 9:20 am

heyzelchi wrote:

the blower fans does not come on and the climate control works properly the problem is that it no heat or a/c coming out of the vents at all

I tested mine this way. I located the blower motor, turned the key to the 'On' position and set the fan to high speed on the climate control unit. Then I played with the wires connected to the blower motor. The motor did not do anything. Then I grabbed onto the motor itself and pushed it in various directions (it doesn't move much, but there is some play). I found that when I pushed it toward the front of the car, it worked full speed. When I let go, it either didn't work at all or it worked only at partial speed. I then assumed that the blower motor was the problem, and it was.

Of course, had things turned out differently I would have probably had to do more tests (I had a step-by-step list in the service manual but wanted to try my own brand of troubleshooting first). So IMO, if I were you, I'd wiggle the wires around and wiggle the motor around a bit and go from there.
Back to top Go down
Sponsored content





In need of some advice for 95 rivi Empty
PostSubject: Re: In need of some advice for 95 rivi   In need of some advice for 95 rivi Empty

Back to top Go down
 
In need of some advice for 95 rivi
Back to top 
Page 1 of 1
 Similar topics
-
» FAQ: Series I Performance Mods?
» How do the mice get in?
» Mod Advice
» In need of your advice
» Looking for advice

Permissions in this forum:You cannot reply to topics in this forum
Riv Performance ::   General Tech :: Interior-
Jump to: