Riviera Performance
Would you like to react to this message? Create an account in a few clicks or log in to continue.

The 8th Gen Riviera Resource
 
HomeDashboardSearchRiviera Questions & AnswersWrite-Ups IndexRegisterRelated LinksLog in

 

 riviera turning over but not getting any spark from module

Go down 
5 posters
AuthorMessage
bigriv0
Amateur



Age : 34
Location : Fayetteviile NC
Joined : 2008-03-16
Post Count : 33
Merit : 0

riviera turning over but not getting any spark from module Empty
PostSubject: riviera turning over but not getting any spark from module   riviera turning over but not getting any spark from module EmptyMon Sep 14, 2009 7:54 pm

I changed the ignition module, crank sensor, ECM and plugs but there is no spark coming from the module please help if you can...Thanks!!!
Back to top Go down
Rickw
Guru



Name : Rick
Location : Lancaster, MA
Joined : 2008-09-13
Post Count : 6281
Merit : 117

riviera turning over but not getting any spark from module Empty
PostSubject: Re: riviera turning over but not getting any spark from module   riviera turning over but not getting any spark from module EmptyMon Sep 14, 2009 8:13 pm

Check all the ground wires. There is one that comes off the Ignition Control Unit and is bolted to the block under the ICM. That one gets broken easily or just corroded.
Remove the coil packs from the ICM and check the condition of the bottoms of them for corrosion, clean with scotchbrite pad or emery paper. Also pull the ICM again and check the underside and top of it for corrosion, same thing there, clean all corrosion and put a light film of dielectric grease on the mating surfaces. All those components need a clean path to ground.
Back to top Go down
bigriv0
Amateur



Age : 34
Location : Fayetteviile NC
Joined : 2008-03-16
Post Count : 33
Merit : 0

riviera turning over but not getting any spark from module Empty
PostSubject: Re: riviera turning over but not getting any spark from module   riviera turning over but not getting any spark from module EmptyMon Sep 14, 2009 10:13 pm

another thing after i changed the PCM it stumbles the entire time it is cranked and the only way it stays cranked is if i hold the gas down (still sounds real rough and you can tell its not getting any gas)
Back to top Go down
deekster_caddy
Master



Name : Derek
Age : 50
Location : Reading, MA
Joined : 2007-01-31
Post Count : 7717
Merit : 109

riviera turning over but not getting any spark from module Empty
PostSubject: Re: riviera turning over but not getting any spark from module   riviera turning over but not getting any spark from module EmptyTue Sep 15, 2009 9:01 am

what do you mean 'stays cranked'? Will it start, but run very rough? Or are you holding the starter (cranking)? Please elaborate.
Back to top Go down
Rickw
Guru



Name : Rick
Location : Lancaster, MA
Joined : 2008-09-13
Post Count : 6281
Merit : 117

riviera turning over but not getting any spark from module Empty
PostSubject: Re: riviera turning over but not getting any spark from module   riviera turning over but not getting any spark from module EmptyTue Sep 15, 2009 10:14 am

Also, will it not even crank (starter rotating) unless you have the gas pedal pushed to the floor.?
What happens if you lift your foot off the gas pedal while the key is turned to the start position and starter is cranking?
Does it just stop cranking as if you turned the key off.?
Back to top Go down
redbaron
Amateur



Name : Joseph Contardi
Location : North East PA
Joined : 2021-05-21
Post Count : 34
Merit : 2

riviera turning over but not getting any spark from module Empty
PostSubject: Re: riviera turning over but not getting any spark from module   riviera turning over but not getting any spark from module EmptyThu Jun 16, 2022 6:55 pm

95 riv. Changed crank sensor, cam pos, ICM, coil packs. Was hard starting hot, but now no spark at any time. ICM ground is good. Any suggestions?
Back to top Go down
albertj
Master
albertj


Name :
Location : Finger Lakes of New York State
Joined : 2007-05-31
Post Count : 8470
Merit : 179

riviera turning over but not getting any spark from module Empty
PostSubject: Re: riviera turning over but not getting any spark from module   riviera turning over but not getting any spark from module EmptyFri Jun 17, 2022 1:58 pm

redbaron wrote:
95 riv. Changed crank sensor, cam pos, ICM, coil packs. Was hard starting hot, but now no spark at any time. ICM ground is good.  Any suggestions?

just post in one thread, or one new thread, next time...

I understand why you changed the crank and cam sensors - one of the most common reasons a car is hard to start when warm is a wack crankshaft or camshaft position sensor. However, it could also be caused by a clogged air filter, faulty battery connection, vapor lock, or one or another bad ground connection (just fixed this, coil grounds, on a Volvo); also by a bad fuel pump (they tend to run good when cool and quit after a while), or bad fuel pressure regulator (they fill with gas, then when the car's off they bleed out),

So tell us, what else did you check? And do you have the factory service manual?
Back to top Go down
Sponsored content





riviera turning over but not getting any spark from module Empty
PostSubject: Re: riviera turning over but not getting any spark from module   riviera turning over but not getting any spark from module Empty

Back to top Go down
 
riviera turning over but not getting any spark from module
Back to top 
Page 1 of 1
 Similar topics
-
» Troubleshooting help needed!! '93 Riv - was No Spark, now won't crank also!
» No spark in 1995 Riviera
» 1995 buick riviera supercharged has no spark
» Noises when turning right
» Interior Lamps Not Turning Off

Permissions in this forum:You cannot reply to topics in this forum
Riviera Performance ::   Turbocharged V6 Tech :: 3.8L V6 Turbo Engine & Transmission-
Jump to: